LabVIEWでライブラリファイル(LLB)を作成するにはどうすれば良いですか?

更新しました Nov 18, 2018

使用製品

Software

  • LabVIEW Full

問題

新規または既存のVIから新しいLLBファイルを作成するにはどうすればよいですか?

解決策

LabVIEW 8.5以降:
1. 新しいプロジェクトを作成するか、既存のプロジェクトを開きます。ブロックダイアグラムまたはフロントパネルから新規プロジェクトを作成するには、ファイル>>新規>>プロジェクト>>空のプロジェクトを選択します。LabVIEWの新規画面から新規プロジェクトを作成するには、プロジェクトを作成を選択します。

2. マイコンピュータ>>新規>>ファイルを右クリックして、プロジェクトにVIを追加します。

3. ビルド仕様>>新規>>ソース配布を右クリックします。


 
4. ソース配布プロパティウィンドウの左側にあるカテゴリーリストでソースファイルを選択します。



5. プロジェクトファイルウィンドウからVIを選択し、右矢印ボタンをクリックすると、VIが常に含むに入り、LLBビルドに含まれます。

6. ソース配布プロパティウィンドウの左側にあるカテゴリーリストで出力先を選択します。

7. 出力先タイプオプションの下にあるLLBラジオボタンをクリックします。


 

LabVIEW 8.0および8.2の場合:
1.ビルド仕様>>新規>>ソース配布を右クリックします。



2. カスタムラジオボタンをクリックします。

3. 出力先はLLBのチェックボックスをクリックし、ポップアップウィンドウではいをクリックします。



4. ビルドをクリックします。


既存のVIを新しいLLBファイルに配置する別の方法は、次のとおりです。
  1. ファイルメニューから名前を付けて保存を選択します。
  2. 元のファイルを閉じてコピーを編集を選択します(元のVIは変更されず、コピーは別の場所に保存されます)。
  3. 継続ボタンをクリックします。
  4. 右下にある新規LLB... ボタンをクリックします。新しいLLBファイルに対する名前を付けて場所を選択します。

     
  5. VIを新しいLLBファイルの中に保存します。

新しいVIを作成して新しいLLBに保存するには、空白のVIを開き、ファイルメニューから保存を選択し、手順4と5を実行します。

メモ: この方法では、LLBにサブVIが自動的に含まれません。依存するVIをLLBに含める必要がある場合は、How Do I Create a LabVIEW VI Library that Automatically Includes All SubVIs?の手順を参照ください。

LLBを処理する別の方法は、LLBマネージャ(LabVIEW 8.5以降)を使用することです。
  1. ツールメニュー>>LLBマネージャ...に移動します。
  2. 新しいLLBを保存するフォルダに移動します。
  3. ファイル>>新規LLBを選択してLLBの名前を入力します。
  4. 作成したLLBにVIを追加するには、VIに移動してLLBマネージャからコピーします。
  5. LLBファイルに移動して開き、VIを貼り付けます。

 

この記事はお役に立ちましたか?

いいえ