¿Cómo creo un archivo de biblioteca (LLB) en LabVIEW?

Actualizado el Jan 9, 2020

Reportado en

Software

  • LabVIEW Full
  • LabVIEW

Detalles del problema

¿Cómo creo un nuevo archivo LLB a partir de un VI nuevo o existente?

Solución

LabVIEW 8.5 y versiones posteriores:
1. Crea un nuevo proyecto o abre uno existente. Para crear un nuevo proyecto desde el diagrama de bloques o el panel frontal, seleccione File»New»Project»Empty Project . Para crear un nuevo proyecto desde la pantalla de introducción de LabVIEW, seleccione Empty Project .

2. Agregue un VI al proyecto haciendo clic con el botón derecho en My Computer»New»File .

3. Haga clic derecho en Build Specifications»New»Source Distribution.

4. Seleccione Source Files en la lista de categorías a la izquierda de la ventana de propiedades de las distribuciones de origen.



5. Seleccione un VI en la ventana Archivos de proyecto y haga clic en el botón de flecha derecha para incluir siempre el VI en la compilación LLB.

6. Seleccione Destinations en la lista de categorías a la izquierda de la ventana de propiedades de distribución de origen.

7. Haga clic en el botón de opción LLB debajo de las opciones de Tipo de destino (Destination type).


Para LabVIEW 8.0 y 8.2:
1.Haga clic derecho en Build Specifications»New»Source Distribution.



2. Haga clic en el botón de radio Custom.

3. Haga clic en la casilla de verificación Destination is LLB y haga clic en Yes en la ventana emergente.



4. Haga clic en Build.

Otra forma de colocar un VI existente en un nuevo archivo LLB es la siguiente:
1. Seleccione Save As en el menú Archivo.
2. Seleccione Substitute Copy for Original (el VI original se mantendrá sin cambios y una copia se guardará en una ubicación diferente).
3. Haga clic en el botón Continue .
4. Haga clic en el botón New LLB en la esquina inferior derecha. Elija un nombre y una ubicación para el nuevo archivo LLB.



5. Guarde su VI dentro del nuevo archivo LLB.

Para crear un nuevo VI y guardarlo en un nuevo LLB, abra una vi en blanco, seleccione Save en el menú Archivo y siga los pasos 4 y 5.

Nota: este método no incluirá automáticamente subVI en la LLB. Si necesita tener dependientes incluidos en la LLB, siga las instrucciones del siguiente artículo: ¿Cómo creo una biblioteca de LabVIEW VI que incluya automáticamente todos los SubVI?

Otra forma de manejar un LLB es usar el Administrador de LLB (LabVIEW 8.5 y versiones posteriores):
1. Vaya al menú Tools»LLB Manager ...
2. Navegue a la carpeta donde desea guardar el nuevo LLB



3. Seleccione File»New LLB e ingrese el nombre de la LLB.
4. Para agregar VI al LLB creado, navegue hasta el VI y cópielo desde el LLB Manager.
5. Navegue hasta el archivo LLB, ábralo y pegue el VI.