使用 VI Package Manager 安裝 LabVIEW Interface for Arduino 工具包

更新 Feb 11, 2019

產品資訊

Software

  • LabVIEW
  • Third Party Add-Ons

問題敘述

我想使用 LabVIEW Interface for Arduino。如何使用 VI Package Manager (VIPM) 安裝 LabVIEW Interface for Arduino 工具包?
 

解決方案

要安裝該工具包,請完成以下步驟:
  1. 確保您的系統上安裝了最新版本的 VI Package Manager (VIPM)。您可以在 VI Package Manager 免費下載 VIPM 社區版。
  1. 啟動VIPM
如果 VIPM 無法啟動,則很有可能是 LabVIEW 中的 VI Server 設定出現問題。請參閱 VI Package Manager (VIPM) Can't Connect to LabVIEW 以執行故障排除步驟。
  1. 在列表中找到 LabVIEW Interface for Arduino
  1. 點擊 Install & Upgrade Packages 按鈕。
  1. 點擊 Continue
您會看到一個視窗,提示 LabVIEW 將重新啟動。點擊確定時,LabVIEW 在重新啟動時將提示您保存所有已開啟的 VI。
  1. 點擊 Finish


LabVIEW Interface for Arduino 現在已經安裝在您的系統上。安裝工具包後,您可以使用 VIPM 檢查其更新。當工具包有更新時,VIPM 中的圖標將更改為如下圖所示。單擊 Upgrade Packages 按鈕將工具包更新到最新版本。

您現在已經可以使用 LabVIEW 中的 Arduino palette。將 LabVIEW Interface for Arduino 韌體安裝到 Arduino 後,您可以使用此 palette 與其互動。有關如何設置韌體的步驟請參閱 How Do I Load the LabVIEW Interface for Arduino Firmware onto My Arduino Uno?

相關資訊

注意:LabVIEW Interface for Arduino (LIFA) 工具包已被 LINX 取代。由於 LIFA 已停止開發,強烈建議移轉到 LINX。請參閱 How To Download Digilent LINX For LabVIEW? 來了解更多信息。

LabVIEW Interface for Arduino (LIFA) 是 LabVIEW 的第三方外掛。NI透過 ni.com/arduino 論壇討論區為其提供支援,該論壇有許多 Arduino/LabVIEW 用戶。您還可以在那裡找到文件,範例和分享知識。

JKI VI Package Manager 僅適用於 LabVIEW,與 LabVIEW NXG 不相容。

本文是否有幫助?

無幫助