Prompt to Install the .NET Framework Before Installing NI Software

Updated Dec 13, 2017

Reported In

Software

  • LabVIEW 2016 Full
  • LabVIEW 2017 Full
  • LabVIEW 2012 Full

Other

  • Microsoft .NET Framework 4.0
  • Microsoft .NET Framework 4.6.1
  • Microsoft .NET Framework 4.6.2

Issue Details


When trying to run an NI installer, I see the following message dialog:

Microsoft .NET Framework 4.0 is required before you can install this product.

Click OK to install the .NET Framework 4.0 now (You may need to reboot your computer after you install .NET Framework 4.0.) Click Cancel to exit this installer.




Why is Microsoft .NET Framework required before installing NI software?

Note: If you are using LabVIEW 2016, then the .NET Framework 4.6.1 is required. If you are using LabVIEW 2017 then the .NET Framework 4.6.2 is required. These newer versions of the .NET Framework can be used to support software that requires an older .NET version.

Solution


National Instruments software makes use of features of the Microsoft .NET Framework 4.6.2 or earlier, and therefore this framework is needed on a system to use National Instruments software. The compatible versions of the .NET Framework for a specific product are listed within its readme.

If the proper .NET Framework is not detected on your system prior to software installation, NI installers will ask you to install the framework before continuing.

Microsoft's policy for software that installs the Microsoft .NET Framework 4.6.2 and earlier states that a reboot may be required before installing any other software. NI installers honor this reboot request.  After rebooting, you can restart the NI installer and installation of your NI software will proceed. Attempting to install NI software without rebooting could cause errors described in the article Error 1935 When Installing NI Software.

Additional Information

For silent, large-scale distribution of software, NI recommends installing the necessary .NET Framework separately before attempting to install NI software. If you attempt to install NI software silently on computers that do not have the .NET Framework installed, you will get one of the following return codes:
  • 11641 – This code is returned if the .NET Framework pre-installation is successful, a reboot is required, and the reboot has been initiated.  No NI software is installed.
  • 13010 – This code is returned if the .NET Framework pre-installation is successful and a reboot is required but is suppressed. The installer simply exited. No NI software is installed. If you attempt to run the installer again with rebooting, you will see the errors discussed in Error 1935 When Installing NI Software.
  • 11603 – This code is returned if there is an error with the .NET Framework pre-installation. The installer exited, and no NI software is installed.
For more information about Microsoft .NET Framework or to install it directly, refer to Microsoft's website.

WAS THIS ARTICLE HELPFUL?

Not Helpful