在Measurement&Automation Explorer(MAX)中导入/导出系统配置

更新 Jul 23, 2019

适用于

Software

  • Measurement & Automation Explorer (MAX)

Driver

  • NI-DAQmx

问题详述

我想将几个通道/任务相关的配置导出至另一台电脑使用或作为备份。我该如何保存MAX的配置以便在另一个系统上使用或作为备份保留?

解决方案

在MAX中保存NI-DAQmx设备,任务和通道,可以按照以下步骤操作:
  1. 从下拉菜单中选择文件(File)»导出(Export)
  1. 在“ National Instruments配置导出向导(National Instruments Configuration Export Wizard)”对话框中,选择要从中导出配置的系统。然后选择要保存文件的地址。如果不使用默认文件名,则必须键入合适的文件扩展名。可用的文件扩展名包括NI Configuration Export File.nce ),  NI-DAQmx INI File.ini )和NI-DAQmx Tab Delimited Text File.txt )。下表详细介绍了不同文件类型的区别,在导入/导出MAX配置时,可参阅该表来选择合适的文件格式。点击下一步(Next) 。文件格式

  1. 选择需要导出的任务、全局通道和其他任何设置。您可以单独选择每个项目,也可以通过点击“ 全部选中(Check All)”或“ 按产品选择(Check By Product)” 按键进行批量选择。
  1. 点击导出(Export)
  2. 弹出的窗格将显示导出配置的状态报告。您可以编辑和保存此报告,但此操作不是必需的。
  1. 点击完成(Finish)
注意:如果您在一台计算机上将DAQ设备配置为设备1,而您希望在另一台计算机上配置其为设备2,MAX将自动为您更改名称,而无需手动更改。

若要使用已保存的NI-DAQmx设备,任务和通道:
  1. 从下拉菜单中选择文件(File)»导入(Import)
  2. 输入或浏览至包含配置文件的目录路径。然后选择要导入的系统。选择下一步(Next)
  3. 简略的配置树将显示配置文件中保存的所有设备,通道和任务。选中您需要导入项旁边的复选框。
  4. 单击导入(Import)
  5. 弹出的窗格将显示导入配置的状态报告。您可以编辑和保存此报告,但此操作不是必需的。
  6. 单击完成 (Finish)
注意:上述操作也可以在LabVIEW 8.0及更高版本中以编程方式实现。使用系统配置工具包,MAX中的所有配置都可以导出到本地或远程计算机中。


保存传统NI-DAQ虚拟通道:
  1. 打开MAX并从下拉菜单中选择工具(Tools)»传统NI-DAQ配置(Traditional NI-DAQ Configuration)»配置另存为(Save Configuration As) 。
  1. 保存当前配置到文件并关闭MAX。
注意:当启动MAX时,它会搜索最后一次活动的配置文件,并将该文件用作新数据源。您在MAX中所做的任何更改操作都将自动保存到该文件中。保存配置文件还会将该新文件设置为活动的配置文件。若您不想在下次打开MAX时使用保存的配置文件,您可以在下次打开MAX后手动更改活动的配置文件,或重命名保存的配置文件。如果您使用的是第二种方法,MAX将找不到最后一个活动的配置文件,并将自动创建一个新的配置文件。

使用保存的传统NI-DAQ虚拟通道:
  1. 打开MAX并从下拉菜单中选择工具(Tools)»传统NI-DAQ配置(Traditional NI-DAQ Configuration)»设置活动配置(Set Active Configuration)
  2. 浏览并选择已保存的文件。
注意:当您将活动配置设置为已保存的文件后,注意MAX将会一直将该文件作为新数据源,直到您手动使用了其他配置文件或更改了配置文件名。请确保配置文件位于本地计算机上,否则MAX将无法正确加载配置信息。
 

本文是否有帮助?

无帮助