NI-MAX에서 시스템 구성 반출/반입

업데이트 됨 Oct 31, 2018

해당 제품

Software

  • Measurement & Automation Explorer (MAX)

Driver

  • NI-DAQmx

문의사항

다른 컴퓨터로 내보내거나 이동하거나 백업 복사본으로 갖고 싶은 여러 채널 또는 태스크(Task)가 있습니다. MAX 구성을 다른 시스템에서 사용할 수 있도록 저장하거나 백업으로 유지하려면 어떻게해야합니까?

해결책

NI-DAQmx 디바이스, 태스크(Task) 또는 채널을 저장하려면,
  1. 풀다운 메뉴에서 파일(File)»반출(Export) 를 선택하십시오.
  1. 내쇼날인스트루먼트 설정 반출 마법사 대화 상자에서 내보낼 시스템을 선택하십시오. 그런 다음 파일을 저장할 위치를 선택하십시오. 기본 파일 이름을 사용하지 않으면 적절한 확장자로 끝나는 이름을 입력해야합니다. 사용 가능한 파일 유형에는 NI 설정 반출 파일 ( .nce ), NI-DAQmx INI File( .ini ) 및 NI-DAQmx Tab Delimited Text File ( .txt )이 있습니다. MAX에서 반출/ 반입 설정 프로세스에 사용할 파일 유형을 결정하려면 다음 표를 참조하십시오. 다음(Next)을 선택하십시오.

  1. 반출하고자 하는 태스크(Task), 글로벌 채널 및 기타 설정을 선택하십시오. 각 항목을 개별적으로 선택하거나 모두 선택(Check All) 또는 제품 별로 선택(Check By Product) 버튼을 클릭하여 항목을 선택할 수 있습니다.
  1. 반출(Export)를 선택하십시오.
  2. 창에 반출 상태에 대한 보고서가 표시됩니다. 이 보고서는 편집 및 저장 될 수 있지만 필수 사항은 아닙니다.
  1. 마침(Finish)을 클릭하십시오.
참고 : DAQ 디바이스가 하나의 컴퓨터에서 디바이스 1로 구성되어 있고 다른 컴퓨터에서 디바이스 2가되도록하려면 MAX가 자동으로 이름을 변경합니다. 수동으로 변경할 필요가 없습니다.

저장된 NI-DAQmx 디바이스, 태스크(Task) 또는 채널을 사용하려면,
  1. 풀다운 메뉴에서 파일(File)»반입(Import) 를 선택하십시오.
  2. 설정 파일이 들어있는 디렉토리의 경로를 입력하거나 찾아보십시오. 그런 다음 가져올 시스템을 선택하십시오. 다음(Next)을 선택하십시오.
  3. 축약 된 구성 트리는 설정 파일에 저장된 모든 장치, 채널 및 작업을 표시합니다. 가져올 각 항목 옆에있는 확인란을 선택하십시오.
  4. 반입(Import)를 클릭하십시오.
  5. 창에 내보내기 상태에 대한 보고서가 표시됩니다. 이 보고서는 편집 및 저장 될 수 있지만 필수 사항은 아닙니다.
  6. 마침(Finish)을 클릭하십시오.
참고 : LabVIEW 8.0 및 이후 버전에서도 프로그래밍 방식으로이 작업을 수행 할 수 있습니다. 구성 복사 VI를 사용하면 MAX의 모든 설정을 로컬 또는 원격 시스템으로 내보낼 수 있습니다.


이전 버전의 NI-DAQ 가상 채널을 저장하려면,
  1. MAX를 열고 풀다운 메뉴에서 Tools»Traditional NI-DAQ Configuration»Set Active Configuration을 선택하십시오.
  1. 현재 구성을 파일에 저장하고 MAX를 닫으십시오.
참고 : MAX를 실행하면 마지막 활성 설정 파일의 이름을 검색하여 해당 파일을 새 데이터 소스로 사용합니다. MAX에서 변경 한 내용은 자동으로 파일에 저장됩니다. 설정 파일을 저장하면 새 파일이 활성 설정 파일로 설정됩니다. 다음에 MAX를 열 때 저장된 설정 파일을 사용하지 않으려면 다음에 MAX를 열 때 활성 설정 파일을 변경하거나 방금 저장 한 파일의 이름을 바꿀 수 있습니다. 두 번째 옵션을 선택하면 MAX는 마지막 활성 설정 파일을 찾지 않고 새 구성 파일을 만듭니다.

저장된 기존의 NI-DAQ 가상 채널을 사용하려면,
  1. MAX를 열고 풀다운 메뉴에서 Tools»Traditional NI-DAQ Configuration»Set Active Configuration 을 선택하십시오.
  2. 저장된 파일을 찾아서 선택하십시오.
참고 : 활성 설정을 저장된 파일로 설정하면 MAX는 다른 설정 파일을 사용하거나 파일 이름을 변경할 때까지 해당 파일을 새 원본으로 사용합니다. 설정 파일이 로컬 컴퓨터에 있는지 확인하십시오. 그렇지 않으면 MAX에서 설정을 올바르게로드 할 수 없습니다.
 

이 글이 도움이 되셨습니까?

도움 안됨