Measurement & Automation Explorer (MAX)でシステム構成をエクスポート/インポートする

更新しました Nov 22, 2018

使用製品

Software

  • Measurement & Automation Explorer (MAX)

Driver

  • NI-DAQmx

問題

別のコンピュータにエクスポート、移動、移行、またはバックアップコピーとして保存したりしたいチャンネルやタスクがいくつかあります。MAXの構成を保存して別のシステムで使用したり、バックアップとして保持するにはどうしたらいいですか?

解決策

NI-DAQmxデバイス、タスク、および/またはチャンネルを保存する方法は以下のとおりです。
  1. プルダウンメニューからファイル>>エクスポートを選択します。
  1. 構成エクスポートウィザードダイアログボックスで、エクスポートするシステムを選択します。次に、ファイルを保存する場所を選択します。デフォルトのファイル名を使用しない場合は、適切な拡張子で終わる名前を入力する必要があります。使用可能なファイルタイプには、NI構成エクスポートファイル(.nce)、NI-DAQmx UTF-8 INIファイル(.ini)、およびNI-DAQmx UTF-16タブ区切りテキストファイル(.txt)があります。次の表を参照して、MAXのエクスポート/インポート設定プロセスで使用するファイルタイプを決定し、次へを選択します。

 

ファイルタイプ特徴
NI構成エクスポートファイル (.nce)完結した構成ファイルで、MAX以外でその構成を編集する必要はありません
NI-DAQmx INIファイル (.ini)MAX以外で編集可能なテキスト形式の構成ファイル
NI-DAQmx タブ区切りテキストファイル(.txt)スプレッドシートとしての編集にも適したテキスト形式の構成ファイル
 


 

  1. タスク、グローバルチャンネル、およびエクスポートするその他の設定を選択します。すべてチェックまたは製品別に選択ボタンをクリックして項目を選択することで各項目を個別に選択することができます。

 
  1. エクスポートを選択します。
  2. ペーンには、エクスポートのステータスに関するレポートが表示されます。このレポートは編集して保存することができますが、編集は必須ではありません。

 
  1. 終了をクリックします。

メモ: DAQデバイスが1台のコンピュータでデバイス1に設定されていて、それを別のコンピュータ上のデバイス2にしたい場合、MAXは自動的に名前を変更します。 手動で変更する必要はありません。


保存されたNI-DAQmxデバイス、タスク、および/またはチャンネルを使用する手順は、以下のとおりです。
  1. プルダウンメニューからファイル>>インポートを選択します。
  2. 構成ファイルを含むディレクトリへのパスを入力するか参照します。 次に、インポートするシステムを選択して、次へを選択します。
  3. 簡略化された構成ツリーには、構成ファイルに保存されているすべてのデバイス、チャンネル、およびタスクが表示されます。インポートするには、各項目の横にあるチェックボックスにチェックを入れますオンにします。
  4. インポートをクリックします。
  5. ペーンには、インポートのステータスに関するレポートが表示されます。このレポートは編集して保存することができますが、編集は必須ではありません。
  6. 終了をクリックします。

メモ: これは、LabVIEW 8.0以降でプログラム的に実行することもできます。MAX構成をコピーVIを使用すると、MAXのすべての設定をローカルマシンまたはリモートマシンにエクスポートできます。


従来型NI-DAQの仮想チャンネルを保存する方法は、以下のとおりです。
  1. MAXを開いて、ツール>>従来型NI-DAQ構成>>プルダウンメニューから構成を保存を選択します。

 
  1. 現在の構成をファイルに保存し、MAXを閉じます。

メモ: MAXを起動すると、最後にアクティブな構成ファイルの名前が検索され、そのファイルが新しいデータソースとして使用されます。MAXで行った変更は自動的にファイルに保存されます。構成ファイルを保存すると、新しいファイルも有効な構成ファイルとして設定されます。次にMAXを開いたときに保存した構成ファイルを使用したくない場合は、次にMAXを開くときにアクティブな構成ファイルを変更するか、保存したばかりのファイルの名前を変更する必要があります。2番目のオプションを選択すると、MAXは最後の有効な構成ファイルを検出せず、新しい構成ファイルを作成します。


従来型NI-DAQの仮想チャンネルをロードする方法は、以下のとおりです。
  1. MAXを起動して、ツールメニュー>>従来型NI-DAQ構成>>アクティブコン構成を選択を選択します。
  2. 保存したファイルを参照して選択します。

メモ: アクティブな構成を保存したファイルを設定するときは、別の構成ファイルを使用するかファイル名を変更するまで、MAXはそのファイルを新しいソースとして使用します。構成ファイルがローカルマシン上にあることを確認してください。そうしないと、MAXが正しく構成をロードできません。

この記事はお役に立ちましたか?

いいえ