Export/Import the System Configuration in Measurement & Automation Explorer (MAX)

Updated Jul 6, 2018

Reported In

Software

  • Measurement & Automation Explorer (MAX)

Driver

  • NI-DAQmx

Issue Details

I have several channels and/or tasks that I want to export, move, or migrate to another computer and/or to have as a backup copy. How can I save my MAX configuration so that I can use it on another system or keep as a backup?

Solution

To save NI-DAQmx devices, tasks, and/or channels:
  1. Select File » Export from the pull-down menu.
  1. In the National Instruments Configuration Export Wizard dialog box, select which system you want to export from. Then select the location where you wish to save your file. If you do not use the default file name, you must type a name that ends with the appropriate extension. Available file types include NI Configuration Export File (.nce), NI-DAQmx INI File (.ini), and NI-DAQmx Tab Delimited Text File (.txt). Refer to the following table to determine which file type to use for the export/import configuration process in MAX. Select Next.

  1.  Select the tasks, global channels, and any other settings you wish to export. You can select each item individually or you can select items by clicking the Check All or Check By Product button.
  1. Select Export.
  2. A pane displays a report on the status of the export. This report may be edited and saved, but this is not required.
  1. Click Finish.
Note: If you have a DAQ device configured to be Device 1 on one computer and you want it to be device 2 on another computer, MAX will automatically change its name for you. There is no need to change it manually.

 To use saved NI-DAQmx devices, tasks and/or channels:
  1. Select File » Import from the pull-down menu.
  2. Type or browse the path to the directory containing the configuration file. Then select the system to import to. Select Next.
  3. An abbreviated configuration tree displays all devices, channels, and tasks saved in the configuration file. Check the checkbox next to each item you wish to import.
  4. Click Import.
  5. A pane displays a report on the status of the export. This report may be edited and saved, but this is not required.
  6. Click Finish.
Note: This can also be done programmatically in LabVIEW 8.0 and later. Using the Copy Configurations VI, all the settings from MAX can be exported to a local or remote machine.


To save Traditional NI-DAQ virtual channels:
  1. Open MAX and select Tools » Traditional NI-DAQ Configuration » Save Configuration As from the pull-down menu.
  1. Save your current configuration to a file and close MAX.
Note: When you launch MAX, it searches for the name of the last active configuration file and uses that file as the new data source. Any changes you make in MAX are automatically saved to the file. Saving the configuration file also sets the new file as the active configuration file. If you do not want to use your saved configuration file the next time you open MAX, you can either change the active configuration file the next time you open MAX or simply rename the file you just saved. If you choose the second option, MAX will not find the last active configuration file and will create a new configuration file.

To use saved Traditional NI-DAQ virtual channels:
  1. Open MAX and select Tools » Traditional NI-DAQ Configuration » Set Active Configurationfrom the pull-down menu.
  2. Browse to and select the saved file.
Note: When you set the active configuration to a saved file, remember that MAX will use that file as its new source until you use another configuration file or change the file name. Make sure that your configuration-file is on the local machine, otherwise MAX could not load the configuration correctly.
 
 

WAS THIS ARTICLE HELPFUL?

Not Helpful