How to Download Measurement & Automation Explorer (NI-MAX)

Updated Aug 7, 2019

Reported In

Software

  • Measurement & Automation Explorer (MAX)
  • System Configuration

Issue Details

  • How do I download NI Measurement & Automation Explorer (NI MAX)?
  • I want to download and install NI-MAX, but I cannot find the file anywhere. Where can I find this software?
  • I want to revert back to an older version of NI-MAX, but I don't know how. Is this possible? 
  • I have a corrupted version of NI MAX, how can I update it to a newer version? 

Solution

NI MAX cannot be downloaded by itself. It is included with all National Instruments drivers (NI-VISA, NI-DAQmx, etc.), and in the NI System Configuration Full package. The NI System Configuration Full package contains NI MAX, the System Configuration API, and the NI Network Browser. It is the closest to a direct download for MAX. You will need the full version instead of the NI System Configuration Run-Time download.

Installing the latest version of any driver or NI System Configuration will automatically install the latest version of NI MAX. You can download earlier versions of MAX by downloading the driver associated with it. Check Measurement & Automation Explorer (MAX) Version Installed with NI-DAQmx Drivers to determine which version of NI-DAQmx to download to get a specific version of NI-MAX.

Your computer will default to using the most recent version of NI-MAX installed. If you need to use a previous version of NI-MAX, you will need to uninstall more recent drivers from your computer.

Check Uninstall or Repair National Instruments Software or Drivers in Windows for instructions on how to uninstall NI-MAX. It is important to note that to uninstall NI-MAX you must allow the removal of all of the NI packages and programs that are connected to NI-MAX to proceed with the un-install. When reinstalling software, use the Software Platform Bundle as this is an effective way of optimising the speed of this process.

Note: Before upgrading any drivers or the System Configuration API, make sure your hardware and software stack are compatible with the new version. This information can be found in the new software's readme file, and in other convenient charts like NI-DAQmx and LabVIEW Compatibility.

WAS THIS ARTICLE HELPFUL?

Not Helpful