Using Both NI GPIB and Keysight HPIB Controllers in the Same System

Updated Dec 1, 2017

Reported In

Hardware

  • GPIB-USB
  • GPIB-USB-HS+
  • GPIB-USB-HS

Software

  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional
  • LabWindows/CVI Full
  • LabWindows/CVI Base

Driver

  • NI-VISA

Issue Details

I have NI GPIB cables in a system, can I use Keysight HPIB cables in the same system?

Solution

You can use NI-VISA 2.5 or higher to access Keysight GPIB controllers, such as HPIB, and National Instruments GPIB controllers, such as PCI-GPIB, in the same system. To do so, you will need to enable the VISA Passport editor in Measurement & Automation Explorer (MAX). The directions for enabling the VISA Passport editor are given below for different versions of MAX. NI-VISA finds and accesses any GPIB or VXI devices. Although the Keysight hardware will show up in MAX and NI VISA Interactive Control, NI-VISA does not configure the Keysight hardware; you must use the Keysight I/O configuration utility to configure that hardware. 

Note: To determine which version of MAX you have, launch MAX and go to Help » About.

If you installed NI-VISA first, you can install Keysight VISA as a secondary VISA, this is only valid if you have Keysight VISA version K and later. If you installed Keysight VISA first, during the installation of NI-VISA, you will be given the choice of either overwriting the other VISA or aborting the installation. 

Measurement & Automation Explorer 5.x and Later
To use the VISA Passport editor in MAX 5.x and later, select Tools » NI-VISA » VISA Options... Once the VISA Options screen appears, select Passports in the tree view (My System » General Settings » Passports). Enable the NiVisaTulip.dll by placing a check mark in the box beside it and then click on the Save button. You will need to restart MAX for the setting to take effect. Once MAX is restarted, you will be able to access your third-party GPIB boards and give them VISA aliases under My System » Devices and Interfaces » Miscellaneous VISA Resources.

Measurement & Automation Explorer 4.x
To use the VISA Passport editor in MAX 4.x, select Tools » NI-VISA » VISA Options... Once the VISA Options screen appears, select Passports in the tree view (My System » General Settings » Passports). Enable the NiVisaTulip.dll by placing a check mark in the box beside it and then click on the Save button. You will need to restart MAX for the setting to take effect. Once MAX is restarted, you will be able to access your third-party GPIB boards and give them VISA aliases under My System » Devices and Interfaces » Miscellaneous VISA Resources.

Measurement & Automation Explorer 3.1
To use the VISA Passport editor in MAX 3.1, select Tools » NI-VISA » VISA Options... Once the VISA Options screen appears, select Passports in the tree view (My System » VISA Settings » Passports). Enable the NiVisaTulip.dll by placing a check mark in the box beside it and then click on the Save button. You will need to restart MAX for the setting to take effect. Once MAX is restarted, you will be able to access your third-party GPIB boards and give them VISA aliases under My System » Devices and Interfaces » Miscellaneous VISA Resources.

Measurement & Automation Explorer 3.0
To use the VISA Passport editor in MAX 3.0, select Tools » NI-VISA » VISA Options... Once the VISA Options screen appears, select Passports in the tree view (My System » VISA Settings » Passports). Enable the NiVisaTulip.dll by placing a check mark in the box beside it and then click on the Apply button. You will need to restart MAX for the setting to take effect. Once MAX is restarted, you will be able to access your third-party GPIB boards and give them VISA aliases under My System » Devices and Interfaces » Miscellaneous VISA Resources.

Measurement & Automation Explorer 2.2 and previous
To use the VISA Passport editor in MAX 2.2 and prior, select Tools » NI-VISA » Passport Editor and enable the NiVisaTulip.dll. 

LabVIEW 
Uninstall NI-VISA, and install HP-VISA. Use the VISA functions in LabVIEW to access the HPIB board.

By default, a VISA resource name constant or control will only allow devices defined in Measurement & Automation Explorer (MAX). Since HPIB boards using HP-VISA will not be found by MAX, you must right-click on the control or constant and select "Allow Undefined Names." This will allow you to manually enter the address of the instrument. Then, you must get the proper board and instrument address from the Keysight I/O configuration utility. Once you have that information, type the resource name according to the standard convention GPIBx::y::INSTR, where x is the board index number (usually 0) and y is the primary address of the instrument.

LabWindows/CVI
1. Uninstall NI-VISA, and install HP-VISA.
2. Make sure you see the board in the Keysight / HP I/O Configuration Utility. Note the proper board and instrument address from here.
3. Use VISA commands in LabWindows™/CVI addressing the instrument according to the standard convention: GPIBx::y::INSTR

Additional Information

If you have both National Instruments and Keysight GPIB controllers in the same system, you must configure the boards with different interface names, such as one as GPIB0 and the other as GPIB1. If both vendors try to use the same interface address, NI-VISA reports an error from viFindRsrc or VISA Find Resources.

NI-VISA will assign an Keysight GPIB card a VISA interface name of GPIBn where n is the trailing number of the SICL name assigned by the Keysight IO Config program. If the SICL name does not have a trailing number, the n will be assigned from the logical unit number assigned by the Keysight IO Config program. If Keysight VISA has configured an NI-488 GPIB card, it will normally default the SICL name to GPIB0. The VISA Library Passport for Tulip will then map this back to NI-VISA as GPIB0. This will conflict with the GPIB0 that is already mapped to the NI-488 GPIB card in NI-VISA. This conflict will cause NI-VISA to not recognize the GPIB interface.

The workaround for this problem is to run Keysight IO Config and edit the SICL name for this card to something else to prevent the conflict (e.g. GPIB9). This will then map to GPIB9 in NI-VISA and not cause a conflict with GPIB0.

If you do not need to have the NI and Keysight GPIB boards in the machine at the same time, but wish to have both drivers installed, see Using Keysight (HP Agilent) 82357A/82357B GPIB in Measurement & Automation Explorer (MAX) or LabVIEW.

Note: HP-VISA and HP-SICL are not National Instruments drivers. Please consult Keysight's website at www.Keysight.com to download these drivers.

WAS THIS ARTICLE HELPFUL?

Not Helpful