This content is not available in your preferred language.

The content is shown in another available language. Your browser may include features that can help translate the text.

Modify a Multisim Subcircuit or Hierarchical Block Symbol

Updated May 3, 2019

Reported In

Software

  • Multisim Full

Issue Details

  • I created a subcircuit for my schematic and I do not like the default symbol, how do I modify the symbol?
  • I created a component and I want to use my own symbol for it, how do I load it into the Symbol Editor?

Solution

The following steps show how to modify a subcircuit or a hierarchical block symbol:
  1. Select the subcircuit you want to modify by left-click on it
  2. Select Edit»Edit Symbol/Title Block to launch the symbol editor 
  3. In the Symbol Editor make the changes you want such as re-arrange the pins, draw a new graphic or import a bitmap.
  4. Once you are a happy with the symbol you created, select File»Exit.
Note: Do not select File»Save As and save the file in a different location, Multisim will not find it.
  1. You will be asked if you want to save the changes click the Yes button to exit the Symbol Editor.
The following steps show how to load a block symbol to a component:
1. Select the component you want to modify.
2. Select  Tools»Component Wizard to create or modify the component.
3. Follow the steps until you get to Step 3 of 8 window. Click on Edit to launch the Symbol Editor.
4. Once in the Symbol Editor you can make changes to the symbol or click File»Open to load a symbol previously created from your computer.
5. Once you are happy with the symbol you created select File»Exit.
 
Note: Do not select File»Save As and save the file in a different location, Multisim will not find it.
 
6. Click Next to continue the creation of the component.

WAS THIS ARTICLE HELPFUL?

Not Helpful