VI Package Manager (VIPM)가 LabVIEW에 연결이 되지 않습니다.

업데이트 됨 Mar 26, 2019

해당 제품

Software

  • JKI VI Package Manager
  • LabVIEW Full
  • LabVIEW Base
  • LabVIEW Professional

문의사항

VI Package 파일을 LabVIEW에 설치하려고 합니다. Install 버튼을 클릭하고, VI Package Manager가 LabVIEW에 연결을 시도합니다. 대기 화면이 나타납니다. 하지만 그 이후에 시간이 더 지나면, 아래와 같이 Batch Process Error 다이얼로그 박스가 나타납니다. 


Batch Process Error VIPM could not continue. Please fix the error and try again. The following critical error occurred:

VIPM could not connect to LabVIEW XX.X. VIPM requires LabVIEW access as part of the current task execution in progress.

해결책

VI Package Manager는 VI 서버를 사용하여 LabVIEW에 연결합니다. 정확하지 않은 VI 서버 구성은 타임아웃을 유발합니다. 정상적으로 연결하려면 LabVIEW와 VI Package Manager 연결 프로토콜을 유사하게 구성해야 합니다.

LabVIEW에서 VI 서버 연결을 설정하려면 다음 단계를 완료하십시오.

  1. 도구»옵션 을 클릭하여 옵션 대화 상자를 시작하십시오.
  2. 왼쪽의 범주 섹션에서 VI 서버를 선택하십시오.
  3. 프로토콜 섹션의 TCP/IP 확인란에 체크 표시를 하십시오.
  4. 포트(Port) 번호를 기억하십시오. 3363이 기본 포트 번호입니다. 기본값을 사용할 필요는 없지만, LabVIEW와 VI Package Manager는 동일한 포트 번호로 설정되어야합니다. 컴퓨터에 여러 개의 LabVIEW 버전이 설치되어있는 경우 각각에 다른 포트가 표시됩니다. 아래 그림은 완료된 프로토콜 섹션을 보여줍니다.

  1. 머신 접근(Machine Access) 섹션에서 추가(Add) 버튼을 클릭하여 새 컴퓨터를 추가합니다.
  2. 아래 그림과 같이 머신 이름/주소 필드에 localhost를 입력하십시오.(localhost가 작동하지 않으면, 모든 연결을 허용하면서 일시적으로 머신 접근 리스트(Machine access list)*를 추가 할 수도 있습니다. 이는 문제가 VI 서버의 액세스 제한으로 인한 것인지를 나타냅니다.)

Note: 머신 접근 리스트에서 *를 제거 할 때 아래와 같이 Warning 1이 표시 되면 External Link: JKI: Resolving issues with VIPM connecting to LabVIEW를 따르십시오 .

VI Package Manager에서 VI 서버 연결을 설정하려면 다음 단계를 완료하십시오.

  1. Tools»Options 을 클릭하여 옵션 대화 상자를 시작하십시오.
  2. LabVIEW 탭을 클릭하십시오.
  3. 포트 번호가 이전에 구성된 LabVIEW VI Server 포트 번호와 일치하는지 확인하십시오. 필요한 경우 Edit 아이콘을 클릭하여 포트 번호를 변경하십시오.
  4. OK 버튼을 클릭하십시오.

완성 된 LabVIEW 환경 설정은 아래 그림을 참조하십시오 :

VI Package Manager가 LabVIEW를 다시 시작합니다. LabVIEW가 다시 시작되면 VI Package Manager가 연결을 설정하고 패키지를 설치할 수 있습니다.

위의 단계가 작동하지 않으면 컴퓨터에 있는 방화벽이나 바이러스 백신 소프트웨어를 끄십시오. 또한 관리자 권한으로 VI Package Manager를 실행하고, 시작 메뉴의 프로그램에서 프로그램을 찾아 마우스 오른쪽 버튼을 클릭하고, 관리자 권한으로 실행을 선택하십시오 .

다른 자료를 원하시면 VIPM의 작성자인 JKI's Support에 문의 할 수 있습니다.

추가 정보

VI Package Manager 찾기

VI Package Manager에는 여러가지 화면으로 표시 될 수 있습니다. 기본 화면에서는 패키지를 설치할 수 있고, 다른 사람이 제공한 옵션을 표시합니다. 이 화면중 하나는 설치를 위해서 사용할 수 있는 다양한 도구와 애드온이 있는 LabVIEW Tools Network입니다. Package Manager의 기본 화면은 아래 그림에서 볼 수 있습니다.

VI Package Manager의 기본 화면을 보려면, 다음 이미지와 같이 LabVIEW Tools Network 창에서 Window»Show VI Package Manager를 클릭합니다:

이 글이 도움이 되셨습니까?

도움 안됨