VI Package Manager (VIPM) Can't Connect to LabVIEW

Updated Mar 26, 2019

Reported In

Software

  • JKI VI Package Manager
  • LabVIEW Full
  • LabVIEW Base
  • LabVIEW Professional
  • LabVIEW

Issue Details

When I try to install a VI Package file in LabVIEW or try to install a LabVIEW Add-on from VI Package Manager, VI Package Manager is not able to connect to LabVIEW. This prevents me from being able to install the file because a wait screen appears and after time elapses I see one of the following errors:
 
  • Error 1:
VIPM - Batch Process Error

VIPM could not continue. Please fix the error and try again. The following critical error occured:
 
VIPM could not connect to LabVIEW XX.X. VIPM requires LabVIEW access as part of the current task execution in progress. 
 
It's possible that LabVIEW XX.X took longer than 120 seconds to launch. Try increasing the timeout value in your VIPM Options. Also, please verify the VI Server: Connection TCP/IP port setting in LabVIEW XX.X. Make sure this matches the port configured in the VIPM Options.
 
This error is also shown in the dialog box below:


 
  • Error 2:
VIPM - Batch Process Error

VIPM could not continue. Please fix the error and try again. The following critical error occured:

 
VIPM could not connect to LabVIEW 20xx. VIPM requires LabVIEW access as part of the current task execution in progress. 
 
Please verify the VI Server: Exported VIs and Machine Access setting in LabVIEW 20xx. Make sure you are allowing access to VIPM by specifying "localhost" in the allowed list.
 
This error is also shown in the dialog box below:
 

Solution

VI Package Manager uses VI Server to connect with LabVIEW. An incorrect VI Server configuration may result in a timeout. For a successful connection, the LabVIEW and VI Package Manager connection protocols must be configured similarly. Follow the steps for configuring the VI Server connection in LabVIEW and in VI Package Manager listed below:

Complete the following steps to configure the VI Server connection in LabVIEW.

  1. Open LabVIEW and click Tools » Options to launch the Options dialog box.
  2. Select VI Server from the Category section on the left.
  3. Place a checkmark in the TCP/IP checkbox in the Protocols section.
  4. Remember and make note of the current Port number. 3363 is the default port number. You do not need to use the default, but both LabVIEW and VI Package Manager must be set to the same port number. If you have multiple LabVIEW versions installed in your computer, you will see a different port for each one. The following example shows a completed Protocol section:

  1. Click the Add button in the Machine Access section to add a new machine.
  2. Enter localhost in the Machine name/address field, as in the following dialog box: (If localhost doesn't work, you could also try adding * to the machine access list temporarily, allowing all connections. This indicates if the problem is due to the access restrictions of the VI server)

Note: If you are getting an error, when trying to remove the * off of your Machine Access list, follow the Resolving issues with VIPM connecting to LabVIEW article. The error you will see is the following:

 


Warning 1 occured at Security Warning When Modifying VI Server TCP/IP Access

Possible reason(s):

Modifying the machine access list or the user and group access list does not affect VI Server clients that are currently connected to this TCP/IP server.

To disconnect clients currently connected, disable TCP/IP access from the VI Server:Configuration page and click OK.

This error is also shown in the dialog box below:


Complete the following steps to configure the VI Server connection in VI Package Manager.

  1. Open VI Package Manager and click Tools » Options to launch the Options dialog box.
  2. Click the LabVIEW tab.
  3. Confirm the Port number matches the previously configured LabVIEW VI Server port number. Click the edit icon to change the port number if needed.  
  4. Click the Verify button.

Refer to the following dialog box for an example of a completed LabVIEW configuration:

VI Package Manager will then restart LabVIEW. When LabVIEW starts back up, the VI Package Manger will establish a connection, and you will be able to install packages.
 

Note: If the above steps do not work, you can also try the following:

  • Turn off any firewalls or antivirus software you have on your computer. If using Windows, you can do this by opening up the Control Panel and going to System and Security » Windows Defender Firewall » Allow an app or feature through Windows Defender Firewall. Verify that LabVIEW 20xx and VI Package Manager are allowed to communicate through the Windows Defender Firewall.
  • Run the VI Package Manager in Administrator Mode by right-clicking the application shortcut found in the Start menu and selecting Run as Administrator
  • Ensure that any updates made to the VI Package Manager have completed and that VI Package Manager is up to date. Go to VI Package Manager General Options for instructions on how to check for updates every time you launch VI Package Manager.
  • You can also contact JKI's support as another resource, as they are the author of this tool. 

Additional Information

Finding the VI Package Manager

There are multiple Windows which can be displayed in the VI Package Manager. The main window will allow you to install packages, while other windows give you other options. One of these windows is the LabVIEW Tools Network, which has a variety of tools and add-ons available for installation. The main window of the package manager is seen in the image below:

To show the VI Packager Manager main window, click Window » Show VI Package Manager in the LabVIEW Tools Network window, as in the following image:    

WAS THIS ARTICLE HELPFUL?

Not Helpful