如何将仪器驱动或VI添加到函数选板中

更新 Dec 6, 2018

适用于

Software

  • LabVIEW Full
  • LabVIEW Base

问题详述

在LabVIEW的函数选板中添加一个仪器驱动程序或自定义的VI。

解决方案

按照以下步骤将自定义子VI或仪器驱动程序添加到函数选板:

 

1.在桌面上创建一个新文件夹,并把所有将作为子菜单的VI复制到该文件夹。如果要创建自定义子菜单,则需要先编辑VI图标,然后再将相关的VI复制到文件夹中(编辑好的图标将显示在子菜单中)。

2.将您在桌面上创建的包含自定义VI的文件夹移动到LabVIEW\Instr.lib这个文件夹中。 Windows系统中这个文件夹的默认位置是C:\Program Files (x86)\National Instruments\LabVIEW XXXX\instr.lib,其中XXXX是您安装的LabVIEW版本,(x86)是指32位的应用程序在64位操作系统中运行。
注意:如果要自定义子菜单,请使用User.lib目录代替Instr.lib

如果要放置自己的子VI文件夹并编辑子菜单图标,请执行以下步骤。

3.启动LabVIEW。

4.在LabVIEW 8.x,2009及以上版本中:
  • 选择Tools » Advanced » Edit Palette Set ...
  • 找到要添加新仪器驱动程序函数选板。 (可能是Functions Palette» Instrument I/O» Instr Drivers。)
  • 在函数选板中右键选择Insert»Subpalette...
  • 选择 Link to an existing palette file (.mnu) 选项,然后单击OK
  • 找到创建好的仪器驱动程序文件夹。
  • 在该仪器驱动程序文件夹内打开Public文件夹。 选择.mnu 文件,然后选择OK
  • 仪器驱动图标现在应该包含在函数选板中。
5.在LabVIEW 7.0中:
  • 选择Tools » Advanced » Edit Palette Views以启用子选项板编辑。
  • 在LabVIEW函数选板中,找到在Instr.libUser.lib中新创建的子文件夹。新添加的子VI文件夹将显示为一个通用子菜单图标。
  • 右键单击子菜单图标以显示包含外观和标题的编辑选项菜单。
  • 更改完成后,单击编辑控件和函数选项板窗口上的保存更改按钮。
6.在LabVIEW 6.0或6.1中:
  • 在函数选板上左键单击Instrument Libraries图标(或User Libraries图标),然后显示出现的窗口。
  • 左键单击搜索按钮右侧的Options按钮。
  • 左键单击Edit Palettes按钮。
  • 您添加到Instr.lib文件夹的子VI文件夹将显示为通用子菜单图标。 右键单击此图标,然后从弹出菜单中选择Edit Submenu
  • 创建您想要的图片(对于大多数仪器驱动程序,此步骤是不必要的)。
7.关闭LabVIEW以使更改生效。

8.启动LabVIEW。

9.从程序框图中,您现在应该可以在Instrument Libraries下看到新的子菜单(如果将VI放在User.lib文件夹中,则是在User Libraries下)。要将这个新建的子菜单移到其他计算机,只需将您创建的文件夹保存到 Instr.lib(或User.lib文件夹)到磁盘。在目标计算机上,将该文件夹的副本放入目标计算机的 Instr.lib(或User.lib)文件夹。启动LabVIEW时,在函数选板中会有新的子菜单。

相关信息

.mnu扩展名用于函数选板文件。

本文是否有帮助?

无帮助