함수 팔레트에 인스트루먼트 드라이버 또는 VI를 추가하는 방법

업데이트 됨 Dec 5, 2018

해당 제품

Software

  • LabVIEW Full
  • LabVIEW Base

문의사항

LabVIEW의 함수 팔레트에 인스트루먼트 드라이버 또는 사용자가 지정한 VI를 추가하고 싶습니다.

해결책

다음 단계에 따라 함수 팔레트에 사용자 정의 subVI 또는 인스트루먼트 드라이버를 추가하십시오.

1. 바탕 화면에 새 폴더를 생성하고 하위 메뉴에 포함될 모든 VI를 복사하십시오. 사용자 라이브러리를 생성하는 경우, VI 아이콘을 폴더에 복사하기 전에 편집해야합니다 (편집 된 아이콘은 하위 메뉴에 표시됩니다).

2. VI가 포함된 바탕 화면에서 생성한 폴더를 LabVIEW\Instr.lib 폴더로 이동하십시오. Windows에서 National Instruments 폴더의 기본 위치는 C:\Program Files(x86)\National Instruments\LabVIEW XXXX\ instr.lib입니다. 여기서 XXXX는 설치된 LabVIEW 버전이고, (x86)은 64-bit 운영 체제에서 실행되는 32-bit 프로그램을 의미합니다.
참고 : 사용자 정의 메뉴를 작성하는 경우, Instr.lib 대신 user.lib 디렉토리를 사용합니다.

자신 만의 SubVI 폴더를 배치하고, 하위 메뉴 아이콘을 편집하는 경우 다음 단계를 따르십시오.

3. LabVIEW를 시작하십시오.
4. LabVIEW 8.x, 2009 및 상위 버전 :
  • 도구»고급»팔레트 세트 편집 ...으로 이동하십시오.
  • 새 인스트루먼트 드라이버 팔레트를 추가할 팔레트를 탐색하십시오. (대부분 함수 팔레트»인스트루먼트 I / O»인스트루먼트 드라이버에 위치합니다.)
  • 팔레트 창을 마우스 오른쪽 클릭 하고 삽입»서브팔레트 ...를 선택하십시오.
  • 기존 팔레트 파일(.mnu)에 링크걸기 옵션을 선택하고 확인을 누릅니다.
  • 장비 드라이버 폴더를 찾으십시오.
  • 인스트루먼트 드라이버 폴더에서 Public 폴더를 엽니다. .mnu 파일을 선택하고 확인을 누릅니다.
  • 이제 인스트루먼트 드라이버 팔레트가 함수 팔레트에 포함됩니다.
5. LabVIEW 7.0에서 :
  • 도구»고급»팔레트보기 편집으로 이동하여 서브 팔레트 편집을 활성화하십시오.
  • LabVIEW Functions Palette에서 Instr.lib 또는 User.lib 서브 팔레트에서 생성한 새 하위 폴더로 이동하십시오. 추가한 SubVI 폴더는 일반 하위 메뉴 아이콘으로 나타납니다.
  • 하위 메뉴 아이콘을 마우스 오른쪽클릭 하면 모양 및 제목 편집을 포함하는 편집 옵션 메뉴가 나타납니다.
  • 변경 한 후에는 함수 팔레트 편집창에서 저장버튼을 클릭 하십시오.
6. LabVIEW 6.0 또는 6.1에서 :
  • 함수 팔레트에서 인스트루먼트 드라이버 메뉴 (또는 사용자 하위 메뉴의 사용자 라이브러리 메뉴)를 클릭 하고 나타나는 창을 고정하십시오.
  • 검색 버튼 오른쪽에있는 옵션 버튼을 마우스 왼쪽 버튼으로 누릅니다.
  • 팔레트 편집 단추를 마우스 왼쪽 버튼으로 누르십시오.
  • Instr.lib 폴더에 추가 한 SubVI 폴더는 일반 하위 메뉴 아이콘으로 나타납니다. 이 아이콘을 마우스 오른쪽 버튼으로 클릭하고 팝업 메뉴 에서 하위 메뉴 편집 아이콘을 선택하십시오.
  • 가지고 싶은 그림을 만드십시오. (이 단계는 대부분의 인스트루먼트 드라이버에서 필요하지 않습니다).
7. 변경 사항을 적용하려면 LabVIEW를 닫으십시오.
8. LabVIEW를 시작하십시오.
9. 블록 다이어그램에서 인스트루먼트 라이브러리 메뉴 아래에 새 하위 메뉴가 표시됩니다 (또는 VI를 User.lib 폴더에 넣으면 사용자 라이브러리에 하위 메뉴가 표시됩니다). 이 새 하위 메뉴를 다른 컴퓨터에 생성하려면 생성 한 폴더를 Instr.lib (또는 User.lib 폴더)에 디스크로 저장하면됩니다. 대상 컴퓨터에서 대상 컴퓨터의 Instr에 폴더의 복사본을 넣습니다. Instr.lib (또는 User.lib ) 폴더에 있습니다 .LabVIEW 를 실행하면 함수 팔레트에 새 하위 메뉴가 있어야 합니다.

추가 정보

.mnu 확장자는 팔레트 파일에 사용됩니다.

이 글이 도움이 되셨습니까?

도움 안됨