関数パレットに計測器ドライバまたはVIを追加する方法

更新しました Jun 19, 2019

使用製品

Software

  • LabVIEW Full
  • LabVIEW Base

問題

LabVIEWで関数パレットに計測器ドライバまたはカスタマイズしたVIを追加したいです。

解決策

次の手順に従って、カスタムのサブVIまたは計測器ドライバを関数パレットに追加します。

  1. デスクトップに新しいフォルダを作成し、サブメニューの一部になるすべてのVIをその中にコピーします。カスタムサブメニューを作成する場合は、VIアイコンをフォルダにコピーする前にVIアイコンを編集する必要があります(編集されたアイコンはサブメニューに表示されます)。
     
  2. VIを含むデスクトップで作成したフォルダをLabVIEW¥Instr.libフォルダに移動します。WindowsでNational Instrumentsフォルダのデフォルトの場所は、C:¥Program Files(x86)¥National Instruments¥LabVIEW XXXX¥instr.libです。ここで、XXXXはインストールされているLabVIEWバージョン、64ビットオペレーティングシステムで動作している32ビットプログラムには(x86)が含まれます。

    サブVIの独自フォルダを配置し、サブメニューのアイコンを編集する場合は、次の手順を行います。

    メモ: カスタムサブメニューを作成する場合は、Instr.libの代わりにUser.libディレクトリを使用します。
     
  3. LabVIEWを起動します。
    • LabVIEW 8.x、2009以降の場合:
      1. ツール>>上級>>パレットセットを編集...に移動します。
      2. 新しい計測器パレットを追加するパレットに移動します(これは、ほとんどの場合、関数パレット>>計測器I/O>>計測器ドライバです)。
      3. パレットウィンドウを右クリックして、挿入>>サブパレット...を選択します。
      4. 既存のパレットファイル(.mnu)にリンクするオプションを選択し、OKを押します。
      5. 参照をクリックして計測器ドライバフォルダを見つけます。
      6. 計測器ドライバフォルダ内で、パブリックフォルダを開きます。 .mnuファイルを選択し、OKを選択します。
      7. これで、計測器ドライバパレットが関数パレットに含まれるようになります。
     
    • LabVIEW 7.0の場合:
      1. ツール>>上級>>パレットビューを編集に移動して、サブパレットの編集を有効にします。
      2. LabVIEW関数パレットで、Instr.libまたはUser.libサブパレットで作成した新しいサブフォルダに移動します。追加したサブVIのフォルダは、一般的なサブメニューアイコンとして表示されます。
      3. サブメニューアイコンを右クリックすると、外観とタイトルの編集を含む編集オプションのメニューが表示されます。
      4. 変更した後、制御器と関数パレットを編集ウィンドウの変更を保存ボタンを左クリックします。
     
    • LabVIEW 6.0または6.1の場合:
      1. 関数パレットの計測器ドライバメニュー(またはカスタムサブメニューのユーザライブラリメニュー)を左クリックし、表示されたウィンドウをタックダウンします。
      2. 検索ボタンの右側にあるオプションボタンを左クリックします。
      3. パレットを編集]ボタンを左クリックします。
      4. Instr.libフォルダに追加したサブVIのフォルダは、一般的なサブメニューアイコンとして表示されます。 このアイコンを右クリックし、ポップアップメニューからサブメニューを編集を選択します。
      5. 必要な画像を作成します(この手順はほとんどの計測器ドライバでは不要です)。
 
  1. 変更を有効にするには、LabVIEWを終了します。
  2. LabVIEWを起動します。
  3. ブロックダイアグラムから、計測器ライブラリメニュー(またはUser.libフォルダにVIを置く場合はユーザライブラリ)の下に新しいサブメニューが表示されます。この新しいサブメニューを他のコンピュータに移植するには、作成してInstr.lib(またはUser.libフォルダ)に移動したフォルダをディスクに保存するだけです。ターゲットマシンでは、フォルダのコピーをターゲットコンピュータのInstrフォルダに入れます。lib(またはUser.lib)フォルダに移動します。LabVIEWを起動すると、関数パレットに新しいサブメニューが表示されます。

追加情報

.mnu拡張子は、パレットファイルに使用されます。

この記事はお役に立ちましたか?

いいえ