How to Add an Instrument Driver or VI to the Functions Palette

Updated May 15, 2018

Reported In

Software

  • LabVIEW Full
  • LabVIEW Base

Issue Details

I want to add an Instrument Driver, or a VI that I've customized, to my Functions Palette in LabVIEW.

Solution

Follow the next steps to add custom subVIs or instrument drivers to the functions palette:

 

1. Create a new folder on your desktop and copy all of the VIs that will be part of the submenu into it. If you are creating a custom submenu, then you need to edit the VI icons before copying them into the folder (the edited icon is what you will see in the submenu).

2. Move the folder you created in your desktop containing your VIs into the LabVIEW\Instr.lib folder. The default location of the National Instruments folder in Windows is C:\Program Files (x86)\National Instruments\LabVIEW XXXX\instr.lib, where XXXX is the LabVIEW version you have installed, and (x86) refers to 32-bit programs running in 64-bit operating systems.
NOTE: If you are creating a custom submenu, use the User.lib directory instead of the Instr.lib.

Follow the next steps just if you are placing your own folder of subVIs, and editing the submenu icon.

3. Launch LabVIEW.
4. In LabVIEW 8.x, 2009, and above:
  • Go to Tools » Advanced » Edit Palette Set ...
  • Navigate to the palette where you want to add your new instrument driver palette. (This will most likely be Functions Palette» Instrument I/O» Instr Drivers.)
  • Right-click in the palette window and select Insert»Subpalette...
  • Select the Link to an existing palette file (.mnu) option and press OK.
  • Browse to find the instrument driver folder.
  • Inside the instrument driver folder open the Public folder. Select the .mnu file and select OK.
  • Your instrument driver palette should now be included in your function palette.
5. In LabVIEW 7.0:
  • Go to Tools » Advanced » Edit Palette Views to enable subpalette editing.
  • In the LabVIEW Functions Palette, navigate to the new subfolder that you created in the Instr.lib or User.lib subpalette. The folder of subVIs that you added will appear as a generic submenu icon.
  • Right-click on the submenu icon to bring up a menu of edit options that include appearance and title editing.
  • After making your changes left-click the Save Changes button on the Edit Control and Functions Palette window.
6. In LabVIEW 6.0 or 6.1:
  • Left-click on the Instrument Drivers menu (or the User Libraries menu for a custom submenu) on the Functions Palette and tack down the window that appears.
  • Left-click the Options button located to the right of the Search button.
  • Left-click the Edit Palettes button.
  • The folder of subVIs that you added to the Instr.lib folder will appear as a generic submenu icon. Right-click on this icon and select Edit Submenu Icon from the pop-up menu.
  • Create the picture that you want to have (this step is unnecessary for most instrument drivers).
7. Close LabVIEW for your changes to take effect.
8. Launch LabVIEW.
9. From the block diagram, you should now see your new submenu under the Instrument Libraries menu (or the User Libraries, if you put your VIs in the User.lib folder). To port this new submenu to other computers, simply save the folder that you created and moved into your Instr.lib (or User.lib folder to a disk. On the target machine, put a copy of the folder into the target computer's Instr.lib (or User.lib) folder. When you launch LabVIEW, you should have the new submenu in your Functions Palette.

Additional Information

The .mnu extension is used for palette files.

WAS THIS ARTICLE HELPFUL?

Not Helpful