My LabVIEW Debugging Tools Are Not Working

Updated Dec 1, 2017

Reported In

Software

  • LabVIEW Full
  • LabVIEW Base

Issue Details

I'm trying to use one of the debugging tools (Highlight Execution, Probe, Step Into, Step Over) but they do not seem to be working in my VI.

Solution

If your debugging buttons are not visible, or if you cannot use the probe tool, the likely cause is that one of the VI Properties (VI Setup in LabVIEW 5.x) prohibits debugging. Here are the most common reasons that the debugging buttons are not visible:
 

  1. The VI is reentrant. You cannot debug a VI while it is marked as reentrant. This property can be changed from File»VI Properties»Execution»Reentrant Execution (VI Setup»Execution Options»Reentrant Execution in LabVIEW 5.x).
  2. Debugging is turned off in the VI. You can adjust this setting from File»VI Properties»Execution»Allow Debugging (VI Setup»Window Options»Allow Debugging in LabVIEW 5.x).
  3. The VI is marked as subroutine priority. VIs may not be debugged while they are marked as subroutine priority. A VI is marked as subroutine priority used File»VI Properties»Execution»Priority (VI Setup»Execution Options»Priority in LabVIEW 5.x).

Additional Information

If you're using the LabVIEW FPGA module, the debugging tools available will depend on the execution mode and the target selected. Please refer to the LabVIEW FPGA module documentation for more information: Debugging FPGA VIs

WAS THIS ARTICLE HELPFUL?

Not Helpful