This content is not available in your preferred language.

The content is shown in another available language. Your browser may include features that can help translate the text.

LabVIEW Load Error Code 3 When Running an Executable

Updated Nov 18, 2021

Reported In

Software

  • LabVIEW Application Builder Module
  • LabVIEW

Driver

  • NI-DAQmx

Issue Details

I built an executable using the LabVIEW Application Builder. When I run it I receive the following error:

LabVIEW load error code 3: Could not load front panel.

Solution

LabVIEW 8.0 and later:
  1. Right-click on the build specification for the executable in your project and select Properties.
 

 
  1. Select the Source File Settings category. Under Project Files, highlight the subVI that needs to have its front panel included. Note that your subVIs must be part of the project in order for them to appear in the Project Files list. [The subVI is mentioned in the error message.]
  2. Uncheck Use default save settings.
  3. Uncheck Remove front panel. 
 

 
  1. Repeat steps 2-4 for any other subVIs that need to have their front panels included.
  2. Build your application

LabVIEW 7.1 and earlier:
  1. Open the Build Application or Shared Library (DLL) window.
  2. Click the VI Settings tab.
  3. Highlight the subVI that needs to have its front panel included.
  4. Press the Edit Build Settings... button at the bottom of the screen.
  5. Select No from the Remove Panel drop-down menu.
  6. Press the Change button at the bottom of the screen.
  7. Repeat steps 3-6 for any other subVIs that need to have their front panels included.
  8. Finish building your application as you normally would.

Additional Information

Other possible causes:
  • This error occurs if your executable displays the front panel of one of the subVIs in your project. When building applications, the LabVIEW Application Builder automatically removes the front panel of all subVIs. These are usually unnecessary and removing them allows for a smaller size of the executable. If your executable loads the front panel of any subVI, you must specify this in the build properties in line with the above solution so that it is excluded when the Application Builder removes front panels of all subVIs.
  • This error can sometimes occur if the software version or a device driver version used on the development machine does not match the run-time engine used on the target machine. For example, if the target computer uses NI-DAQmx 16.0 and the development computer uses NI-DAQmx 17.6, either upgrade the target version or revert on the development to ensure matched versioning.  To download LabVIEW Run-Time Engine and NI-DAQmx check LabVIEW Download and NI Driver Downloads.
  • This error can also sometimes occur when building an application that utilizes NI-DAQmx VIs.  If you see this error specifically for NI-DAQmx VIs, ensure that the driver is installed correctly on the development computer and that the source code runs correctly in the LabVIEW environment. If they do not, ensure that the following NI services are running on your development computer (you can find a list of all installed services in the Windows Services application on your computer.:
    • NI Configuration Manager
    • NI Device Loader
  • This error can occur when there are missing dependencies that the executable needs to run. Make sure that all the dependencies are included in the application configuration. You can add any missing files by right-clicking the executable under the Build Specifications and going to Properties >> Source Files. Click the arrow buttons next to the Always Included listbox to add selected files from the Project Files listbox.
  • Building and running an installer can ensure that all the drivers needed to run the executable are present on a target machine.