Modifying LabVIEW Default Search Paths for SubVIs

Updated Sep 18, 2018

Reported In

Software

  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional

Issue Details

I am unable to locate a subVI after launching my top level VI.  Which file locations does LabVIEW search by default and how can I modify the search paths to locate my custom VIs?

Solution

By default, LabVIEW will look through the following locations in order (\* means LabVIEW will search through the subdirectories):
  • <topvi>\* - the location of the top level VI
  • <foundvi> - the location of the last VI found
  • <vilib>\* - the LabVIEW vi.lib
  • <userlib>\* - user.lib
  • <instrlib>\* - instr.lib
If LabVIEW was unable to find the VI in the expected location or in any of the paths from the above list, you will be prompted to manually locate the VI.  To avoid this, add the subVI's directory to the list of search paths.  You can configure the search paths by going to Tools»Options»Paths and selecting VI Search Path from the drop-down menu

Additional Information

If VIs were not found in the relative paths where LabVIEW expected them due to the SubVIs being moved, LabVIEW will notify you that changes have been detected by placing an asterisk next to the VI name in the window title bar. Saving the main VI afterwards will also save a new relative file path for the subVI. 

If you already have a version of your application that is pointing to the wrong location, you can go in and manually replace the misdirected VIs with the copies you want. Select View»VI Hierarchy with the top level VI open. Go to View»Full VI Path in Label. You will then be able to see the full paths where your VIs are located. You can open the SubVIs and save them to a new location. If you have many subVIs to move, you might choose to correct the problem by moving the entire copy of the application to a new place causing the relative paths to be recreated.

WAS THIS ARTICLE HELPFUL?

Not Helpful