Teststand Deployment Utility Will Not Start Up

Updated Jun 22, 2019

Reported In

Software

  • TestStand
  • LabVIEW

Issue Details

I'm having the following error when I try to launch TestStand Deployment Utility:
 

Solution

  • If you have LabVIEW installed in your computer, check the following steps to identify if the cause of the issue is a corrupt installation of the LabVIEW Application Builder:

1. Create an installer in LabVIEW (not an executable). 
2. If you get errors as well when bulding the installer, it is possible that this issue is caused by a corrupt installation of LabVIEW, which affected the Application Builder for both LabVIEW and TestStand. Take a look at the document Error 1097 When Creating an Installer in LabVIEW to check if this is your case, and follow those steps to fix the issue.
3. Launch TestStand Deployment Utility. 
 

  • If you don't have LabVIEW installed, or if you are able to successfully build installers in LabVIEW but not in TestStand, proceed with a force a repair of the MDF files using the steps below:
  1. Navigate to "C:\ProgramData\National Instruments", then back up and remove the MDF and MIF folders.
  2. Navigate to" <Program Files (x86)>\National Instruments\Shared", then back up and remove the MDF and MIF folders.
  3. Remove and back up the NIMDF.dll located in the "<TestStand>\Components\Tools\Deployment Utility\data\NIMdf.dll"
  4. Repair TestStand, and verify that the folders and file above are recreated
  5. Try to launch TestStand Deployment Utility

 

 

Additional Information

If the error still occurs, check if an MDF log file got created here:
C:\Users\<user>\AppData\Local\Temp\mdf log.txt and contact National Instrument Support​

WAS THIS ARTICLE HELPFUL?

Not Helpful