Required RIO Device Drivers for LabVIEW 2015 and Later

Updated Apr 6, 2018

Reported In

Hardware

  • CompactRIO Controller
  • CompactRIO Single-Board Controller

Driver

  • NI-RIO
  • NI CompactRIO
  • NI-RIO

Issue Details

I have a RIO device and I'm not sure what driver I'm supposed to use. What driver do I need for my RIO device and where can I download these drivers?

Solution

CompactRIO and sbRIO Targets -  Install NI CompactRIO 15.0 or later depending on the version of LabVIEW you are using.

R Series Multifunction RIO devices - Install NI R Series MultifunctionRIO 15.0 or later depending on the version of LabVIEW you are using.

FlexRIO devices - Install NI FlexRIO 15.0 or later depending on the version of LabVIEW you are using.

Note: There may be special cases where you will need to install multiple device drivers depending on the hardware being used. For example, if you are using using the NI 9151 Expansion Chassis with a R Series device. you will also need the CompactRIO Device Driver to use C Series Modules within the 9151 chassis.

Please check this article to find out the specific version of the driver that you could use depending on the LabVIEW version.

Additional Information

With the release of LabVIEW 2015 the NI-RIO Device Drivers have been divided into 3 separate distributions to better support customers using those specific devices.

WAS THIS ARTICLE HELPFUL?

Not Helpful