使用LabVIEW创建NI VeriStand模型时,Linux终端操作系统不可用

更新 Jul 17, 2019

适用于

Software

  • VeriStand
  • LabVIEW

Operating System

  • Linux

问题详述

我想创建一个在Linux终端(例如cRIO 903x)上的VeriStand中运行的LabVIEW模型,但是当我选择“Tools >> NI VeriStand >> Generate Model from VI 时,在终端操作系统 的下拉菜单中,我找不到Linux选项。

解决方案

从LabVIEW 2017开始,用户可以为运行在Linux终端下的VeriStand生成LabVIEW模型。

要获得此功能,必须安装 NI VeriStand LabVIEW Models for NI Linux Real-Time Target
  1. 首先,导航到与您的软件版本匹配的NI VeriStand LabVIEW Models for NI Linux Real-Time Target下载页面
  2. 然后,在产品下载页面的安装说明中列出了为NI Linux实时终端需要的LabVIEW模块
    • 这包括LabVIEW Real-Time,CompactRIO驱动程序,NI VeriStand和Linux的C / C ++开发工具。要求的版本将在您选择的版本的LabVIEW 模型实时终端下载页面上提供
    • 安装适用于NI Linux目标的VeriStand LabVIEW Model之前,必须安装指定版本所需的软件。
  3. 一旦安装/更新了所需的软件,就可以安装与您的软件版本匹配的NI VeriStand模型 NI VeriStand LabVIEW Models for NI Linux Real-Time Targets 
  4. 完成安装后,您现在应该能够在 LabVIEW Tools >> NI VeriStand >> Generate Model from VI >> Target OS 的下拉列表里看到Linux目标选项。

本文是否有帮助?

无帮助