Application Installer Requires Installing LabVIEW Before Setup

Updated Oct 30, 2018

Reported In

Software

  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional

Issue Details

Whenever I try and run an installer created in LabVIEW on my target machine, I get an error message saying: 

You must install LabVIEW 20xx-32/64 bit on this system before you can run this setup. 

Why do I get this error, and how do I resolve it?

Solution

The installer configuration in the application builder includes a setting for requiring the full LabVIEW Development Environment to be installed prior to running your installer.

If this is not the behavior that you are expecting, disable the requirement for the development system by following the instructions below:
  1. In the LabVIEW project where the installer was built, right-click on the installer configuration under the Build Specifications folder and select Properties
  2. Navigate to the Advanced category
  3. Uncheck the Require the LabVIEW 20xx 32/64-bit development system option (see Figure 1)
  4. Rebuild your installer
 


 

Additional Information

This functionality can be useful when the development environment is required to extend certain parts of your application. 

WAS THIS ARTICLE HELPFUL?

Not Helpful