This content is not available in your preferred language.

The content is shown in another available language. Your browser may include features that can help translate the text.

Archived:How Do I Load the LabVIEW Interface for Arduino Firmware onto My Arduino Uno?

Updated Jul 17, 2018

National Instruments does not actively maintain this document.

This content provides support for older products and technology, so you may notice outdated links or obsolete information about operating systems or other relevant products.

Reported In

Software

  • Third Party Add-Ons
  • LabVIEW

Issue Details

I want to use the LabVIEW Interface for Arduino Uno.  How do I load the Arduino firmware onto my Arduino Uno?

Solution

Note: The package LabVIEW Interface for Arduino (LIFA) has been replaced with LINX. It is highly recommended to migrate to LINX as there will be no further development for LIFA. See How To Download Digilent LINX For LabVIEW? for more information.


Following instructions are archived and last testing was done using Arduino 1.0.5. software.

Connect the Arduino Uno to your PC as described in How do I Connect an Arduino Uno to my PC?.
  1. Install the LabVIEW Interface for Arduino toolkit as described in How do I Install the LabVIEW Interface for Arduino Toolkit Using VIPM?.
  2. Open the Arduino IDE by browsing to the folder that you extracted in step 1 and double clicking arduino.exe
  1. The Arduino IDE will open.  Click File»Open and browse to LIFA_Base.ino found in C:\Program Files\National Instruments\LabVIEW 201x\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base
  2. Note: Older versions of the LIFA toolkit use the LVIFA_Base.pde file which would be found in the same location as above.
  1. Choose the Arduino board type by clicking Tools»Board » Arduino Uno
  2. Choose the COM port by clicking Tools » Serial Port and choosing the COM port that corresponds to your Arduino Uno.
  1. You can determine the COM port that corresponds to your Arduino Uno using the device manager by clicking Start » Control Panel»Device Manager and expanding Ports(LTP & COM).
  2. Click the Upload button to upload the firmware to the Arduino Uno.
  1. The Arduino IDE should report Done Uploading when the firmware has been successfully uploaded to the Arduino.
  1. You are now ready to use the Arduino Uno with the LabVIEW Interface for Arduino Uno. The LIFA toolkit contains a number of examples which can be accessed through the functions palette; this is a great place to start.

WAS THIS ARTICLE HELPFUL?

Not Helpful