DIAdem Report Express VI Error -2584

Updated Nov 22, 2017

Reported In

Software

  • DIAdem Full
  • LabVIEW Base
  • DIAdem 9.1 Full

Issue Details

I have both LabVIEW and DIAdem installed on my machine, but when I try to call DIAdem from LabVIEW, I get the following error: 

Error -2584 occurred at DIAdem Report Express VI: DIAdem could not be started. You must have DIAdem 9.1 Service Pack 2 or later installed to use the DIAdem Report Express VI.

I have DIAdem 9.1 Service Pack 2 or later installed. Why am I still gettting this error?

Solution

The bitness of LabVIEW and DIAdem must match. It must be 32-bit LabVIEW to 32-bit DIAdem or 64-bit LabVIEW to 64-bit DIAdem communication. DIAdem also has to have been installed and started at least once before the DIAdem Report Express VI will work. 

You can find out the bitness of your software in NI MAX (Measurement & Automation Explorer). Expand the software tab and find LabVIEW and DIAdem. The 64-bit version will say "(64-bit)" to the right of the software name; the 32-bit will not have any bitness displayed. 

If you discover that the bitness of LabVIEW and DIAdem do not match, you'll need to install a version of DIAdem with the correct bitness.

WAS THIS ARTICLE HELPFUL?

Not Helpful