LabVIEW程序代码更新缓慢

更新 Apr 7, 2022

适用于

软件

  • LabVIEW

问题详述

LabVIEW在加载大型VI时会导致响应缓慢。当我在前面板或框图上移动一个控件或函数时,它会挂起一秒钟,或者移动得非常缓慢。偶尔,当我已打开程序框图时,有些连线会显示不全,只有在我操作该框图时,才会慢慢显示。但是,当我运行LabVIEW以外的程序时,都没遇到程序运行缓慢的行为,请问如何改善这个情况?

解决方案

这个情况可能是因为电脑屏幕使用高分辨率以及多种颜色设置所致。当大型VI的前面板拥有许多的控件需要更新时也会导致这种现象。每当您移动鼠标并在前面板上控制控件时,LabVIEW必须不断地更新前面板绘图。 LabVIEW使用双重缓冲来使屏幕更新更流畅并快速地显示。这个过程包括在进行更新的离线缓冲区绘制窗口内容,然后将新窗口内容复制到前面板。随着分辨率和颜色的深度增加,复制窗口内容将会占用更多的内存。

故障排除具有三个主要路径:
  1. 电脑设定
  2. LabVIEW设置
  3. 代码架构
如果在任何VI上都看到这种缓慢现象,并且与它的大小或所保存的子VI数量无关,请从电脑或LabVIEW设置开始。如果这仅在大型VI中发生,则很可能是由代码结构问题引起的。

电脑设定

若要更正此问题,首先请尝试更改分辨率和颜色设置。请将电脑设置为800 x 600像素的分辨率,256色和60 Hz的刷新率,再更改分辨率和彩色显示设置。您也可以向电脑制造商咨询如何调整屏幕分辨率(例如,Microsoft的Windows 10 更改屏幕分辨率)。


另一个可能的解决方案是更改电脑的“硬件加速”设置。请与电脑制造商联系,以了解如何调整此设置。
  • 对于Windows 7,右键单击桌面,选择显示设置>>屏幕分辨率>>高级设置>>故障排除>>更改设置。从这里可以调整硬件加速设置。建议您尝试降低加速度,以达到您的预期操作。重新启动后,新设置才能生效。

LabVIEW设置

下一个建议是尝试禁用前面板的“平滑更新”设置。

在LabVIEW 2010及更高版本中:
  • 右键单击前面板上的图形,然后选择高级»平滑更新。注意:此方法仅适用于图(Graphs),不适用于图表(Charts)。
  • 减少保存撤消次数以释放一些内存。LabVIEW撤销数量的默认值为99次,而这些撤销将使用内存来存储。
    • 要更改撤消次数,请转到工具»选项。并选择环境类别。将每个VI允许的最大撤消步骤数更改为大约10,以限制内存使用,但仍保持撤消功能。

代码架构

您也可以从代码架构着手来缓解LabVIEW程序代码更新缓慢的问题。
  • 程序缓慢的另一个解决方案是监测VI内存管理。这包括将大型VI的一些小部分保存为子VI,限制全局变量和局部变量的使用,并确保前面板上没有重叠在一起的控件。单击文件»VI属性可找到VI的内存使用情况将类别更改为内存使用。
  • 从程序框图中,您可以从现有代码中创建子VI,方法是选择要成为子VI的代码,然后在工具栏单击编辑»创建子VI,该代码将替换为子VI图标。您可以通过双击图标来编辑子VI。有关将现有代码创建成子VI的更多信息,请参见: 创建子VI
  • 将主程序VI编辑成为独立的VI可以减少程序滞后。为此,请从LabVIEW创建VI,而不是从项目中创建一个VI,然后保存该VI,再正常编辑。
  • 前面板上的银色输入控件和显示控件比经典控件占用的内存更多。要更改此设置,请到文件»VI属性»编辑器选项。在编辑器选项中,将控件样式更改为新式经典。您也可以通过右键单击并选择“替换”来分别更改输入控件和显示控件。
  • 如果大型输入控件或显示控件(例如多个图形)具有默认值,请尝试清除该默认数据并将清除后或空的状态设置为新的默认状态。这样可以释放VI中的一些内存。
    • 要清除图形,请右键单击该图形,选择数据操作>>清除图形。
    • 要设置默认值,请右键单击数据操作>>将当前值设置为默认值。
  • 如果项目最初是用以前的版本编写的,并且尚未编译到当前版本,这可能会导致程序运行速度降低。在VI中,通过转到文件»全部保存来执行保存。
  • 程序框图的大小可能会对VI的性能产生很大影响。建议将框图的大小保持在适当的范围内,最佳大小是使VI程序框图都能在屏幕上显示,并且只需最少的上下左右滑动即可查看代码中的所有内容。当程序框图太大并需要大量滑动时,可能会损害VI的性能。

相关信息

如果这些补救措施都不成功,则可以考虑升级显卡驱动程序或卡本身。您可以在相应制造商的网站上找到最新版本的显卡驱动程序。当您要以高分辨率运行前面板上的多个输入控件或显示控件时,这通常会有所帮助。