LabVIEW NXG Opens VI With Unresolvable or Unloaded Dependency Error

Updated Nov 15, 2017

Reported In

Software

  • LabVIEW NXG 1.0

Issue Details

When I open a VI in LabVIEW NXG, I receive an error saying Unresolvable or unloaded dependency: followed by the name of a subVI. How do I resolve this error?

Solution

Based on the name of the missing VI, find the NI Package Manager package that includes the VI.  Install the package to get the missing subVI. 

If the missing subVI is one that you have created, manually add the subVI to the project. Once the subVI is in the project, your VI should be able to open without errors.

Additional Information

This error occurs when there is a dependency (such as a driver or other VI) that is missing or unable to be found by the project. The subVI causing the error will show up on the block diagram as a placeholder node.

WAS THIS ARTICLE HELPFUL?

Not Helpful