여러 NI 소프트웨어 제품의 설치 순서 정하기

업데이트 됨 May 28, 2019

해당 제품

Software

  • LabVIEW
  • NI Device Drivers

Driver

  • NI-DAQmx

문의사항

  • 여러 개의 내쇼날 인스트루먼트 하드웨어 및 소프트웨어 제품을 구입했습니다. 소프트웨어 및 하드웨어 드라이버에 필요한 설치 순서가 있습니까?
  • 새로운 버전의 LabVIEW(또는 LabWindows ™ / CVI)가 이미 설치된 컴퓨터에 이전 버전의 소프트웨어를 설치해야 합니다. 최신 버전 위에 이전 버전을 설치하는 데 문제가 있습니까?
  • LabVIEW의 최신 버전으로 업그레이드한 후, 일부 VI가 손상되었습니다. 왜 이런 일이 일어났습니까?
  • 방금 NI-DAQmx와 LabVIEW를 설치했지만 DAQ 함수는 LabVIEW에서 사용할 수 없습니다. 어떤 문제가 있습니까?

해결책

시나리오에는 일반적으로 3가지가 있습니다. 본인 환경에 가장 적합한 시나리오를 선택하고 아래의 설치 프로세스를 사용하십시오.
  • 새로운 설치 : 내쇼날 인스트루먼트 소프트웨어 제품이 설치되지 않은 컴퓨터에 설치할 때
  • 업그레이드 : 내쇼날 인스트루먼트 소프트웨어의 최신 버전 설치할 때
  • 이전 소프트웨어 : 이미 설치된 National Instruments 소프트웨어 보다 최신 버전의 National Instruments 소프트웨어를 설치할 때


새로운 설치

설치 프로세스는 ADE(application development environment) 소프트웨어(LabVIEW 또는 LabWindows ™ / CVI)로 시작하여, 모듈, 툴킷 및 드라이버 순으로 진행됩니다.

다음 순서로 응용 프로그램 소프트웨어를 설치하십시오 (해당되는 경우).
  1. LabVIEW 개발 환경
    • 컴퓨터에 여러 버전이 있어야하는 경우, 가장 오래된 버전에서 최신 버전 순으로 설치하십시오.
  2. LabVIEW 애드온 모듈 (예 : LabVIEW Real-Time Module)
    • 컴퓨터에 여러 버전이 있어야하는 경우, 가장 오래된 버전에서 최신 버전순으로 설치하십시오.
  3. LabVIEW 툴킷 (예 : 사운드 및 진동 툴킷)
  4. 기타 어플리케이션 소프트웨어 (예 : Measurement Studio, NI TestStand, DIAdem, NI VeriStand).
  5. 하드웨어 드라이버
    • 참고 : 일반적으로 내쇼날 인스트루먼트 드라이버는 최신 네 가지 버전의 LabVIEW를 지원합니다. 드라이버가 더 이상 이전 하드웨어를 지원하지 않는 경우, 드라이버를 설치하면 컴퓨터의 모든 응용 프로그램에 대한 하드웨어 지원이 제거됩니다. 최신 드라이버가 더 이상 이전 버전의 LabVIEW를 지원하지 않는 경우, 최신 드라이버를 설치하면 이전 버전의 LabVIEW에 대한 지원이 완전히 제거됩니다.
  6. 소프트웨어 및 드라이버를 설치한 후, 필요한 하드웨어를 시스템에 추가/설치하십시오. 운영 체제는 하드웨어를 자동으로 인식하고 설치해야 합니다.


업그레이드

내쇼날 인스트루먼트 소프트웨어를 업그레이드하려면, 업그레이드 프로세스를 확인한 다음, 새로운 설치 프로세스와 같이 설치하십시오.

드라이버 READ ME 파일을 검토(Finding NI Readmes for Supported OS, ADE, Device, Modules and More)하여 새 하드웨어 드라이버에서 기존 하드웨어와 가장 오래된 LabVIEW 버전이 여전히 지원되는 지 확인하십시오. 위 내용이 문제가 없다면, LabVIEW 업그레이드 가이드 문서를 검토하고 새로운 설치 시나리오와 같이 설치하십시오.


이전 소프트웨어

NI 드라이버는 설치할 때, 기존의 설치된 LabVIEW에 대한 지원을 포함합니다. 예를 들어, 대부분의 드라이버는 로우 레벨 하드웨어 지원과 LabVIEW와 같은 어플리케이션 개발 환경을 지원하는 API를 모두 포함합니다.

다음 순서로 응용 프로그램 소프트웨어를 설치하십시오 (해당되는 경우).
  1. 이전 버전의 LabVIEW Development Environment를 설치하십시오 (이전 버전의 LabVIEW 플랫폼 DVD에서 선택 가능).
  2. 이전 버전의 LabVIEW Toolkit 또는 모듈을 설치하십시오.
  3. 최신 버전의 하드웨어 드라이버를 설치하거나 이전 버전의 LabVIEW와 함께 사용할 하드웨어 드라이버를 수정 설치 실행하십시오. 하드웨어의 수정 설치를 진행하려면:
    1. National Instruments 제거 프로그램 (Windows 7에서 시작»제어판»프로그램 및 기능을 클릭하고 National Instruments 항목 추가/제거 선택)을 실행하십시오.
    2. 특정 드라이버로 이동하고 수정 버튼을 선택하십시오.
    3. 설치 관리자의 안내 메세지에 따라 설치를 완료하십시오.

추가 정보

설치 순서를 올바르게 따르지 않을 경우, 구성 설정이나 예제 파일 등이 누락되었을 수 있습니다. 이러한 문제가 발생하면, 기존의 설치된 제품(예 : LabVIEW, TestStand, DIAdem)을 먼저 설치 복구하는 것이 좋습니다. 이 문서(Uninstall or Repair National Instruments Software or Drivers in Windows)를 참조하십시오. 수리를 완료하는 방법에 대한 도움을 받으십시오.

LabVIEW를 제거했다가 다시 설치하는 경우, 위의 설치 순서에 따라 모듈, 툴킷 및 드라이버를 다시 설치해야 합니다. 그렇지 않으면, 일부 제품의 기능이 누락 될 수 있습니다.

여러 버전의 LabVIEW가 설치된 환경 관련 참고 사항 : LabVIEW Development Environment 와 모든 툴킷은 나란히 설치됩니다. 드라이버 설치 관리자는 이전 버전의 드라이버를 업그레이드하고, 컴퓨터에 설치된 어플리케이션 개발 환경 (예 : LabVIEW)에 대한 지원을 추가합니다.

장치 드라이버 업그레이드에 관한 참고 사항 : 2001 년 이후의 모든 드라이버 설치 프로그램은 이전에 설치된 버전의 드라이버를 확인하는 메타 설치 프로그램을 사용합니다. 이전 드라이버가 발견되면 최신 버전을 설치하기 전에 이전 드라이버를 제거합니다. 최신 드라이버가 이미 설치되어 있음을 감지하면 아무 것도 수행하지 않습니다. 2001년 이전에 만든 드라이버 설치 프로그램을 사용하는 경우, 새 버전으로 업그레이드하기 전에 이전 드라이버를 제거하십시오.

순서가 잘못된 설치 결과에 대한 참고 사항 : LabVIEW를 설치하기 이전에 드라이버가 먼저 설치된 경우, LabVIEW는 드라이버를 사용하는 데 필요한 API 레벨 구성 요소를 가지고 있지 않습니다. 이 문제를 해결하려면 (드라이버의 README를 검토하여 기존 하드웨어 및 설치된 가장 오래된 버전의 LabVIEW가 여전히 지원되는지 확인한 후 최신 버전의 드라이버로 업그레이드하거나 현재 드라이버 버전의 수정 설치를 실행하십시오.

이 글이 도움이 되셨습니까?

도움 안됨