Orden de instalación para múltiples productos de software de NI

Actualizado el Sep 9, 2019

Reportado en

Software

  • LabVIEW
  • NI Device Drivers

Driver

  • NI-DAQmx

Detalles del problema

  • Acabo de comprar varios productos de hardware y software de National Instruments. ¿Existe alguna preferencia por el orden de instalación de los controladores de software y hardware de National Instruments?
  • Necesito instalar una versión anterior de LabVIEW (o LabWindows ™ / CVI) en una computadora que ya tenga instalada una versión más nueva de LabVIEW (o LabWindows ™ / CVI). ¿Hay algún problema con la instalación de una versión anterior sobre una versión más reciente? es posible?
  • Después de actualizar a una versión más nueva de LabVIEW, algunos de mis VI están rotos. ¿Cuál podría ser una razón para que esto suceda?
  • Acabo de instalar NI-DAQmx y LabVIEW, pero las funciones DAQ no están disponibles en LabVIEW. ¿Qué ocurre?

Solución

Hay tres escenarios de instalación comunes. Elija el escenario que mejor se adapte a su configuración y utilice el proceso de instalación a continuación como guía.
  • Nueva instalación: instalación en una computadora sin productos de software de National Instrument instalados.
  • Actualización: Instalación de nuevas versiones del software National Instruments.
  • Software más antiguo: Instalar software anterior de National Instruments en una computadora que tenga versiones más recientes del software de National Instruments ya instalado.

 

Nueva instalación

El proceso de instalación comienza con el software del entorno de desarrollo de aplicaciones (ADE) (LabVIEW o LabWindows ™ / CVI), seguido de módulos, Toolkits y los controladores.

Instale el software de su aplicación en el siguiente orden (si corresponde):
  1. Entorno de Desarrollo de LabVIEW
    • Si necesita que haya varias versiones en su computadora, instale desde la versión más antigua a la más reciente.
  2. Módulos adicionales de LabVIEW (por ejemplo, Módulo de LabVIEW Real-Time)
    • Si necesita que haya varias versiones en su computadora, instale desde la versión más antigua a la más reciente.
  3. Toolkits de LabVIEW (por ejemplo, Toolkit de Sound and Vibration)
  4. Otro software de aplicación (por ejemplo, Measurement Studio, NI TestStand, DIAdem, NI VeriStand).
  5. Controladores de hardware
    • Nota: los controladores de National Instruments generalmente admiten las últimas cuatro versiones de LabVIEW. Si el controlador ya no es compatible con su hardware anterior, al instalarlo se eliminará esa compatibilidad de hardware para todas las aplicaciones en su computadora. Si el controlador más nuevo ya no admite sus versiones anteriores de LabVIEW, la instalación del controlador más reciente eliminará completamente el soporte para las versiones anteriores de LabVIEW.
  6. Después de instalar el software y los controladores, agregue / instale el hardware necesario en el sistema. El sistema operativo debe reconocer e instalar el hardware automáticamente.

Mejorar

Para actualizar el software de National Instruments, verifique el comportamiento de la actualización, luego instale como con el proceso de Nueva Instalación.

Verifique que el hardware existente y la versión más antigua instalada de LabVIEW aún sean compatibles con los nuevos controladores de hardware revisando el README del controlador (inglés) (disponible en la página de Descargas y actualizaciones de controladores (inglés) ). Después de revisar lo anterior y, si está satisfecho con el comportamiento de actualización, revise el documento de la Guía de actualización de LabVIEW (inglés) e instale el software como en el escenario de Nueva instalación.

 

Software más antiguo

Cuando se instalan los controladores de NI, incluyen soporte para las instalaciones existentes de LabVIEW. Por ejemplo, la mayoría de los controladores incluyen soporte de hardware de bajo nivel y API para admitir un entorno de desarrollo de aplicaciones como LabVIEW.

Instale el software de su aplicación en el siguiente orden (si corresponde):
  1. Instale la versión anterior del entorno de desarrollo de LabVIEW (opcionalmente de una versión anterior del DVD de la plataforma de LabVIEW).
  2. Instale la versión anterior de cualquier LabVIEW Toolkits o Módulos.
  3. Instale una versión más nueva del controlador de hardware o ejecute una instalación de modificación de los controladores de hardware que desea usar con la versión anterior de LabVIEW. Para ejecutar una instalación de modificación de los controladores de hardware:
    1. Inicie el desinstalador de National Instruments (Inicio »Panel de control» Programas y características en Windows 7 y elija Agregar o quitar la entrada de National Instruments).
    2. Navegue hasta el controlador específico y elija el botón Modificar.
    3. Siga las instrucciones del instalador para completar la instalación.

Información adicional

Si el orden de instalación no se siguió correctamente, es posible que a algunos productos les falten características como las configuraciones o los archivos de ejemplo. Si experimenta estos comportamientos, es mejor reparar la instalación en los productos que se instalaron primero (es decir, LabVIEW, TestStand, DIAdem). 

Si desinstala y vuelve a instalar LabVIEW, también necesitará reinstalar los módulos, los Toolkits y los controladores siguiendo el orden de instalación anterior, de lo contrario, es posible que a algunos productos les falten características.

Nota sobre las múltiples versiones de LabVIEW : El entorno de desarrollo de LabVIEW y todos los Toolkits se instalarán en paralelo con las versiones principales anteriores. El instalador del controlador actualizará las versiones anteriores del controlador y agregará soporte para cualquier entorno de desarrollo de aplicaciones compatible (por ejemplo, LabVIEW) instalado en la computadora.

Nota sobre la actualización de los controladores de dispositivos : todos los instaladores de controladores desde 2001 utilizan un meta instalador que tiene la capacidad de verificar si hay una versión instalada previamente del controlador. Si se encuentra un controlador anterior, lo desinstalará antes de instalar la última versión. Si detecta que el controlador más reciente ya está instalado, no hará nada. Si está trabajando con instaladores de controladores creados antes de 2001, desinstale el controlador anterior antes de actualizar a la versión más reciente.

Nota sobre el resultado de la instalación fuera de servicio: Si se instala un controlador antes de LabVIEW, LabVIEW no tendrá los componentes de nivel API necesarios para usar el controlador. Para resolver este problema, puede actualizar a una versión posterior del controlador (inglés)(después de verificar que su hardware existente y la versión más antigua instalada de LabVIEW aún son compatibles al revisar el archivo README del controlador), o ejecutar una instalación Modificar de su versión actual del controlador.

¿FUE ESTE ARTÍCULO DE AYUDA?

No