VI Package Managerでパッケージ非互換性のエラーが表示される

更新しました Jan 30, 2019

使用製品

Software

  • JKI VIPM Professional

問題

VI Package Manager 2013を使用しており、VI Package Manager 2014でビルドされたパッケージをインストールしようとすると、次のエラーメッセージが表示されます。
This package is not compatible with any LabVIEW version on this computer.  

互換性のあるバージョンのLabVIEWがコンピュータにインストールされています。このエラーを解決するにはどうすればよいですか?

解決策

このエラーは、VI Package Manager(VIPM)2013がVIPM 2014のパッケージ形式を認識しないために発生します。VIPM 2014でビルドされたパッケージはVIPM 2014以降にのみインストールできます。VIPM 2014でビルドされたパッケージは、VIPM 2013以前のバージョンにはインストールできません。VIPMの最新バージョンは無料でダウンロードできます。

アップグレードできない場合、またはVIPM 2014にアップグレードしたくない場合は、互換性のためにVIPM 2013でVIPファイルを再ビルドする必要があります。

パッケージがVIPM 2014でビルドされている場合は、VI Package Manager 2014がパッケージのインストールに必要であることを説明文に含めることをお勧めします。

この記事はお役に立ちましたか?

いいえ