エラー 9: ファイルバージョンは現在のLabVIEWバージョンよりも新しいバージョンです

更新しました Jun 24, 2019

使用製品

Software

  • LabVIEW

問題

VIを開こうとすると、次のようなエラーメッセージが表示されます。これは何を意味するのですか?
 

LabVIEWロードエラーコード9: ファイルバージョンは現在のLabVIEWバージョンよりも新しいバージョンです。

解決策

このエラーメッセージは、現在使用しているLabVIEWのバージョンより新しいLabVIEWのバージョンで作成されたVIを開こうとしたときに表示されます。

新しいバージョンのVIを古いバージョンのLabVIEWで表示することはできません。たとえば、LabVIEW 2017で作成されたサンプルをダウンロードして、LabVIEW 2016(またはそれ以前)でVIを開こうとすると、このエラーメッセージが表示されます。

ただし、LabVIEW 5.1以降では、旧バージョン用に保存オプションを使用して、現在のバージョンよりも1つ以上古いバージョンのLabVIEWバージョン用にVIを保存できます。(例: LabVIEW 2017からLabVIEW 2016で保存)。

これは、LabVIEWからファイル>>オプション付きで保存>>前のバージョンに保存、またはLabVIEW 8.0以降ではファイル>>旧バージョン用に保存を選択して実行できます。
 

 
  • 保存しているバージョンで利用できなかった機能やオブジェクトを使用している場合、LabVIEWはそれらをそのバージョンに保存して戻すことができず、VIが実行不能のままになる可能性があります。
  • それでもエラーが発生する場合は、必要なバージョンのLabVIEWのインストールが失敗しなかったことを確認してください。

追加情報

新しいバージョンのLabVIEWで古いバージョンのLabVIEWのVIを開こうとすると、別の問題が発生する可能性があります。 LabVIEWが旧バージョンのLabVIEWで保存されたVIを開くことができない場合は、以下のメッセージが表示されます。

エラー 1126 (0x466): VIが旧バージョンのため、現在のLabVIEWのバージョンに変換できません。

この場合、新しいバージョンにアップグレードする前に、VIを中間バージョンに保存する必要があります。このエラーの詳細については、チュートリアル: VIをLabVIEWの異なるバージョンにアップグレードまたは戻す方法を参照してください。

この記事はお役に立ちましたか?

いいえ