LabVIEW Load Error Code 9

Updated Mar 25, 2021

Reported In

Software

  • LabVIEW

Issue Details

I get the following error message when I try to open a VI:
LabVIEW load error code 9: VI version is newer than LabVIEW version. 

What does this mean?

Solution

This error message occurs when you try to open a VI that was written in a version of LabVIEW that is newer than the version of LabVIEW that you are currently using. You will not be able to view a VI that is from a newer version of LabVIEW in an older version of LabVIEW.

In order to fix this error, these are some of the steps you can follow:
  • Save the VI for a previous version of LabVIEW: Starting with LabVIEW 5.1, you can save a VI for a version of LabVIEW that is at least one version older than your current version using the Save for Previous Version tool. (i.e. from LabVIEW 2015 to LabVIEW 2014). This can be done from within LabVIEW by navigating to:
    • For LabVIEW 7.1 and previous versions: File » Save with Options » Save for Previous
    • For LabVIEW 8.0 and newer: File » Save For Previous Version.

 
  • Upgrade your LabVIEW development environment to the same version or newer than the one used to develop the VI. After installing LabVIEW, make sure that it is activated by using the NI License Manager and open the development environment of the new version at least once after the installation. After doing this, you should be able to open the VI by double-clicking it. If it still shows up the same error, proceed with opening the new version of LabVIEW and then go to File >> Open... and select the VI manually from the folder where it is located.
  • If you do not have access to a version of LabVIEW capable of opening the VI, the Version Conversion section of our forum is an effective way to reach out to the community for help in reverting VIs.

Additional Information

You may encounter a separate but related issue when trying to open a VI from an older version of LabVIEW in a newer version of LabVIEW. If LabVIEW is unable to open a VI saved in a much older version of LabVIEW, you will receive

error 1126 (0x466): VI version is too early to convert to the current LabVIEW version.

In this case, you may need to save the VI to an intermediate version before upgrading it to a newer version. Please visit Tutorial: How to Upgrade or Revert a VI to a Different Version of LabVIEW for more information on this error.