This content is not available in your preferred language.

The content is shown in another available language. Your browser may include features that can help translate the text.

LabVIEW Load Error Code 9

Updated Jul 21, 2021

Reported In

Software

  • LabVIEW

Issue Details

I get the following error message when I try to open a VI:
LabVIEW load error code 9: VI version is newer than LabVIEW version. 

What does this mean?

Solution

This error message occurs when you try to open a VI that was written in a version of LabVIEW that is newer than the version of LabVIEW that you are currently using. You will not be able to view a VI that is from a newer version of LabVIEW in an older version of LabVIEW.

If you have access to a version of LabVIEW equal to or later than the version of the VI (indicated in the error message), the easiest solution is to use the more recent version of LabVIEW. However, if you do not have permanent access to a more recent version of LabVIEW, you have a few options.
  • Use a later version of LabVIEW to save the VI for a previous version of LabVIEW
    • For instance, if you received this VI from a colleague, have them follow steps to revert the VI before use in the version of LabVIEW you will be using.
  • If you do not have access to a version of LabVIEW capable of opening the VI, the Version Conversion section of our forum is an effective way to reach out to the community for help in reverting VIs.

Additional Information

You may encounter a separate but related issue when trying to open a VI from an older version of LabVIEW in a newer version of LabVIEW. If LabVIEW is unable to open a VI saved in a much older version of LabVIEW, you will receive

error 1126 (0x466): VI version is too early to convert to the current LabVIEW version.

In this case, you may need to save the VI to an intermediate version (between LabVIEW versions 6.0 and 8.5) before upgrading it to a newer version.