Problem Installing the Windows SDK 7.1 for VeriStand Model Compilation

Updated Jul 20, 2018

Reported In

Software

  • VeriStand 2015
  • VeriStand 2015 SP1
  • VeriStand 2016
  • VeriStand 2017 Full

Issue Details

I'm having problems installing the Windows SDK 7.1 on a Windows 8.1 or 10 machine. However, this version of the compiler is required to create models for Windows and PharLap ETS VeriStand systems. How can I install this SDK?

Solution

The following method has been used to successfully install the SDK 7.1 on both Windows 8.1 and Windows 10: 
  1. Uninstall all Microsoft Visual C++ 2010 Redistributable packages (both x86 and x64) via Control Panel » Programs and Features.
 
  • Install the Windows SDK 7.1. During installation, under the Installation Options menu, uncheck Visual C++ Compilers and Microsoft Visual C++ 2010.

 

With the compiler installed successfully, you are ready to compile models for both Windows and PharLap ETS targets.

 

Note: National Instruments can only provide recommendations for installing Microsoft products- as we are not involved with their product releases. These instructions have been tested but cannot be guaranteed.

  • Reinstall the Microsoft Visual C++ 2010 Redistributable packages: x64 and x86.

Additional Information

Also have the IT department check the user settings to make sure that you can edit and read the registry.

WAS THIS ARTICLE HELPFUL?

Not Helpful