このコンテンツは設定された言語で表示できません。

このコンテンツは表示可能な別の言語で表示されています。 お使いのブラウザに翻訳機能がある場合はご利用ください。

Software Needed to Use a myRIO

Updated Jan 19, 2021

Reported In

Hardware

  • myRIO-1900
  • myRIO-1950

Driver

  • NI-RIO

Issue Details

  • Do I need to install any of the RIO Drivers? 
  • What is the minimum software that I need on my computer?

Solution

The corresponding myRIO Toolkit will bring the needed drivers to recognize and program the device, thus you don’t need to install the RIO drivers. A RIO component will show up on NI MAX after installing the myRIO Toolkit.

In order to program your myRIO device the minimum software that needs to be installed is:  Note: If you plan to use the onboard FPGA on the device, you will need LabVIEW FPGA and the Compilation Tools for Vivado installed. 

Additional Information

If you plan to deploy an executable to a target computer that communicates with a myRIO over USB, then you should install the latest version of the CompactRIO Runtime on the target computer. This allows the target computer to recognize the myRIO and create a virtual network connection. CompactRIO Runtime should show up as one of the additional installers you could include when creating an installer to deploy using the build specifications. 

Note: When programming the myRIO using C/C++, LabVIEW and LabVIEW RealTime are not needed.

The optional software components typically used with the myRIO are:
  • LabVIEW Control Design and Simulation Module
  • LabVIEW MathScript RT Module
  • LabVIEW Robotics Module for LabRIO
  • VI Package Manager
  • Vision Acquisition Software
  • Vision Development Module