cDAQ Module Shows as Unsupported Module in MAX with NI-DAQmx

Updated Nov 7, 2018

Reported In

Hardware

  • cDAQ-9171
  • NI-9219
  • NI-9212
  • cDAQ-9174
  • cDAQ-9184
  • NI-9228
  • cDAQ-9188
  • NI-9266
  • cDAQ-9178
  • NI-9210
  • NI-9381

Software

  • Measurement & Automation Explorer (MAX)

Driver

  • NI-DAQmx

Issue Details

  • My cDAQ module shows up as an unsupported device in NI Measurement and Automation Explorer (NI MAX).
  • My C Series module is showing up as not supported. 
  • I upgraded NI MAX, but my module is still showing as Unsupported Module in NI MAX.
  • When I try to use my DAQ devices it tells me that NI cDAQ Unsupported Module.

Solution

General Troubleshooting

  1. Remove the module from the chassis and check for bent or missing pins on the module and chassis. If no issues are found with the pins then try reinserting the module, making sure the module fully seats into the chassis. If improperly seated, your module may show up as Unsupported Module.
  2. Check compatibility between your module and cDAQ chassis or controller. Some modules are not compatible with cDAQ-9172, USB-9162, WLS-9163 or ENET-9163 Gen I cDAQ chassis.
  3. Check compatibility between your module and NI-DAQmx. Some modules have different hardware revisions, such as a DSUB versus a Spring Terminal version, and are supported in different versions of DAQmx. See Module Specific Troubleshooting for more details. 
  4. Check compatibility between your version of NI-DAQmx and Windows.
  5. Check compatibility between your version of NI-DAQmx and LabVIEW
  6. If you are sure you have the correct driver and software versions for your system, and your device is seated properly:
    1. Try resetting your MAX Database.
    2. Try force reinstalling your NI-DAQmx driver.

Module Specific Troubleshooting

  • Select NI-9426 and NI-9475 modules need to be updated to support cDAQ. First, ensure that you are using NI-DAQmx 8.8 or later. Earlier versions of NI-DAQmx did not support the NI-9475 or NI-9426 and will always detect the module as unsupported.
  • If you are using NI-DAQmx 8.8 or later with the NI-9426 or the NI-9475 and are still seeing the module show up as unsupported, NI has identified a limited number of modules that shipped with an incorrect field in the EEPROM. DAQmx will not detect the module correctly in a cDAQ chassis with this EEPROM value. To update the EEPROM, please contact ni.com/support and reference this KnowledgeBase. National Instruments will send you an executable to update the EEPROM. 
     
  • For XNET modules, please see Why Do My XNET Modules Say Unsupported in Measurement and Automation Explorer?, which is also in the related links section below.
  • If you are using the Spring Terminal Variants of the NI-9207, NI-9208, NI-9209, NI-9425, and NI-9476, they may show up as unsupported as they were released after the initial DSUB model. Check NI 9207, 9208, 9209, 9425 or 9476 Not Recognized or Unsupported by NI-DAQmx for more information.
  • The NI-9230 BNC and NI-9232 BNC variants were released after the initial screw terminal variant release, and they require a higher version of NI-DAQmx if used as a drop-in replacement. See general troubleshooting steps above to ensure you are using the correct version of NI-DAQmx.
  • For the Ethernet cDAQ chassis, an upgrade of firmware may be necessary.
  • The 9266 is compatible with a cDAQ chassis as of DAQmx version 18.1. Upgrade your version of DAQmx through our website

Additional Information

Use NI MAX to see what version of NI-DAQmx you currently have installed.

WAS THIS ARTICLE HELPFUL?

Not Helpful