LabVIEWインターネットツールキットの利用可能なバージョン

更新しました Mar 26, 2019

使用製品

Software

  • LabVIEW Internet Toolkit
  • LabVIEW

問題

  • 見つけることができるLabVIEWインターネットツールキットの最終バージョンは2012です。それ以降のバージョンのLabVIEWと互換性がありますか?
  • LabVIEWインターネットツールキットの旧バージョン(2011以前)がインストールされています。それ以降のLabVIEWバージョンと互換性がありますか?
  • LabVIEWインターネットツールキット 2010をダウンロードしようとしていますが、ナショナルインスツルメンツ(NI)のウェブサイトにダウンロードリンクが表示されず、下図のようにメッセージが表示されています。

    旧バージョンにアクセスするには、シリアル番号を登録するか、SSPを更新してください。
     

解決策

LabVIEWインターネットツールキットは廃止され、LabVIEWプラットフォームには同梱されなくなりました。廃止されたAPIは既存のアプリケーションに使用でき、LabVIEWインターネットツールキット2012ではLabVIEW 2013以降のサポートがインストールされますが、ナショナルインスツルメンツは下記のAPIを使用して新規開発を開始することを推奨します。
 

このライブラリのすべての関数は、すべてのLabVIEW開発パッケージにで利用可能になりました。
 

廃止されたAPIの推奨代替API:
 

追加情報

LabVIEWインターネットツールキットダウンロードページ にアクセスすると、LabVIEWインターネットツールキットのバージョン2012以降をダウンロードできます。

選択した特定のバージョンに利用可能なダウンロードリンクがない場合、または次のメッセージが表示された場合は、旧バージョンのNIソフトウェアをダウンロードする方法 を参照してください。

旧バージョンにアクセスするには、シリアル番号を登録するか、SSPを更新してください。

この記事はお役に立ちましたか?

いいえ