Error -366044 With New VST NI 564x

Updated Jan 31, 2018

Reported In

Hardware

  • PXIe-5644
  • PXIe-5645
  • PXIe-5646R-G
  • PXIe-5646

Driver

  • NI-RFSA 15.0
  • NI-RFSG 15.0

Issue Details

I just started using my Vector Signal Transceiver (VST) and I'm getting error -366044 saying The hardware external calibration data format is newer than the latest revision supported by the currently installed software. Upgrade your software.

Solution

VSTs Shipped After March 1, 2016, Require Updated Minimum Driver Versions
  • Install The 2015.11 version of the RF Driver Suite is the recommended method to solve this issue.
  • If you would prefer to download individual drivers, you will need to update NI-RFSA, NI-RFSG, and the VST Instrument Design Libraries (IDLs). NI recommends updating to latest supported version for your VST.
  • To install the patches for previous versions of the VST IDLs please use NI Update Service (Start » All Programs » National Instruments » NI Update Service). Use the information below to determine which installer is best for you.
    Note: The minimum supported LabVIEW version is LV 2012.
    If you are using VST 15.0 IDLs: You need to update to VST 15.0.2 IDLs to use VSTs shipping after March 1, 2016.
    If you are using VST 14.x IDLs: You need to update to VST 14.0.2 IDLs to use VSTs shipping after March 1, 2016.
    If you are using VST 13.x IDLs: You need to update to VST 13.5.2 IDLs to use VSTs shipping after March 1, 2016.

Additional Information

NI has made improvements to the self-calibration procedure for NI 5644R/5645R/5646R/5646R-G that requires an update to the hardware driver. If the part number listed on your VST is the New Module Assembly Part Number, then your VST is affected by this change.
 
 
Note: The x signifies that this change affects all letter revisions with the New Module Assembly Part Number.

You can find your module Assembly Part Number on a left side of module's body.
   

This change does not affect the form, fit or function of the product and should be transparent to the user when used with the updated driver. If you are using driver versions 15.0 or earlier and try to use the device in a Soft Front Panel (SFP) or with the instrument driver API, you will get the error message mentioned in the problem description above. If you are using driver versions 15.0 or earlier and notice that one of your devices does not appear in the VST Self-Calibrate utility, please try to access it with an SFP or the instrument driver API to confirm that you need to update the driver for that device.

WAS THIS ARTICLE HELPFUL?

Not Helpful