LabVIEW FPGA Module Not Installing on Windows 10

Updated Oct 15, 2018

Reported In

Software

  • LabVIEW FPGA Module
  • FPGA Xilinx Compilation Tools

Operating System

  • Windows

Issue Details

I'm trying to install LabVIEW FPGA Module on my Windows 10 computer, and I'm seeing these warning messages pop up keeping me from installing the module. I was able to install this just fine before on my Windows 7 machine.


Unsupported operating system detected.
The LabVIEW 2017 SP1 FPGA Module may install and execute on this operating system, but only the FPGA Interface functions are officially supported. Refer to the readme file of this product for more information.

The Xilinx Compilation Tool for Vivado 2015.4 may install and execute on this operating system, but official support is not provided. Refer to the readme file of this product for more information.

The Xilinx Compilation Tool for ISE 14.7 does not officially support Windows 8 or later. Refer to the readme file of this product for more information.

Solution

When you receive the above messages, it means there may be some incompatibility between the software you are installing and your system.  To identify which FPGA software and build tools are compatible with your Windows 10 computer, and to understand what options you have in regards to LabVIEW FPGA, please reference LabVIEW FPGA Module Compatibility with Windows 10.

Additional Information

The compilation tool you need is dependent on the target you are compiling for. If you want to learn more about which compilation tools are used for which targets, you can reference this: Compatibility between Xilinx Compilation Tools and NI FPGA Hardware.

If you would like more information on what FPGA chip is used in your RIO device, please reference: Xilinx FPGA Chips for National Instruments RIO Devices.

The exact system requirements of each module are listed in the readme file that ships with all the NI software. For more detailed compatibility questions, refer to this document, which should be located in the same folder as the setup.exe file is contained for each module.

ISE 14.7 will not install on incompatible operating systems while Vivado 2015.4 should install, but may encounter errors during operation on unsupported operating systems.

WAS THIS ARTICLE HELPFUL?

Not Helpful