Compiling DLLs for Use with VeriStand Without Development License

Updated Nov 3, 2017

Issue Details

I want to compile a DLL for use with VeriStand, but I'm working on a computer that does not need a full license of VeriStand. Is there a way to compile the DLL without purchasing a complete development system license?

Solution

The NI VeriStand Model Generation Activation Utility allows you to compile DLLs for use with VeriStand without the full development system. Use the following steps to install and activate this feature.
  1. Log onto your PC as administrator or a user with administrator privileges.
  2. Use your preferred web browser to navigate to the NI VeriStand Download Page and select Download NI VeriStand.

Note: The batch installer is approximately 5.88 GB (which includes the NI-DAQmx and NI-VISA drivers) so please be prepared for a potentially long download time.
 
  1. Launch the downloaded installer. Select to install NI VeriStand 201x Evaluation - Serial number not required.
VeriStand Activation Install Evaluation
  1. Select the NI VeriStand 201x Model Framework as the feature to install.
VeriStand Installer Model Generation Model Framework

Note: For creating NI VeriStand Models using the LabVIEW Application Builder, you will also need to install the NI VeriStand 201x LabVIEW Model Support.

VeriStand Installer LabVIEW Model
 
  1. After successfully installing the software, restart your system (do not launch the Activation Wizard at this time). After rebooting, launch NI License Manager, browse to NI VeriStand » Toolkits » Activate Model Generation with the Serial Number S14X86758.

After installing and activating Model Framework and Model Support, you should now be able to develop DLL's in other environments that can interface with NI VeriStand.

Additional Information

The Model Framework allows you to compile DLLs from third party applications for use with NI VeriStand, while the Model Support adds support for LabVIEW Application Builder. If you aren't using LabVIEW Application Builder, you do not need to install Model Support.

WAS THIS ARTICLE HELPFUL?

Not Helpful