將NI Volume License Manager(VLM)遷移到新的伺服器(Server)

更新 May 8, 2026

環境

軟體

  • Volume License Manager

  • 我想遷移,移動或導出NI Volume License Manager(VLM)到新的Server,然後導入配置。我怎樣才能做到這一點?
  • 我們已將 Volume License Server移至具有其他computer ID的新電腦。我們需要採取什麼步驟來使Server在這台新電腦上啟動並運行?

以下是將NI Volume License Manager移動到新Server的推薦步驟。請注意,您的舊Server應保留直到驗證過程成功為止。

在NI VLM 3.0和VLM 3.1中

1.導出License Server Files並設置 
使用File»Backup/Restore NI VLM建立現有NI VLM Server的備份(請參見Creating an NI VLM Backup)

2.新的License File
通過發送您的Service ID,新Server名稱和computer ID至Agreements@ni.com ,並從National Instruments申請新的License File。

3.設置New License Server
在新Server上安裝NI Volume License Manager ,然後Complete the NI VLM Getting Started Wizard。在Importing Settings from Previous NI VLM Installations 中,選擇Import settings from a previous NI VLM 3.x installation 。 並選擇我們在步驟1中創建的備份。
除Getting Started Wizard的內容外,不能使用其他Server的備份。如果需要返回此階段,請參考Backup File Was Created From Another Installation of NI VLM Error
  

從NI VLM 1.0到NI VLM 2.1

1.導出License Server Files並設置

  1. 通過導航到 Options»Save Activity Log...,從舊Server保存Activity Log 。
  2. 保存compliance log 文件,包含有.log文件擴充和配置文件nivlm.cfg。配置文件nivlm.cfg包含權限和Client端信息。因此,移動此文件將使您不必在新Server上重新輸入此信息。這些文件可以在<National Instruments> \ Volume License Manager中找到

2.New License File
向National Instruments申請新的license file。從舊Server發送您的新computer ID和Activity Log。 National Instruments使用您的computer ID, Activity Log和agreement ID來生成新的license file。

3.Setting up a New License Server

  1. 安裝NI Volume License Manager
  2. 通過導航至Options»Install License File...,將新的license file安裝到新Server上。
  3. 將Activity Log和Compliance Log(均具有.log文件擴展名)和新Server上的配置文件nivlm.cfg替換為舊Server中的每個副本。這些文件位於<National Instruments> \ Volume License Manager目錄中。將nivlm.cfg複製到新Server時,請確保新Server上的VLM已關閉。
  4. 導航到 Options»Preferences,在新Server上設置首選項。

附加信息

Client端 修改

以上更改影響Server,而不影響Client端。確保Client端仍指向正確Server的推薦方法是使用舊Server的Windows名稱重命名新Server。如果此選項不可用,請參閱How Do I Point Client Computers to My New Licensing Server?