This content is not available in your preferred language.

The content is shown in another available language. Your browser may include features that can help translate the text.

Migrating NI Volume License Manager (VLM) to a New Server

Updated Oct 17, 2019

Reported In

Software

  • Volume License Manager

Issue Details

  • I would like to migrate, move or export NI Volume License Manager (VLM) to a new server and then import the configuration. How can I do this?
  • We have moved our volume license server to a new computer with a different computer ID. What steps do we need to take to get our server up and running on this new computer?

Solution

Below is the recommended procedure for moving NI Volume License Manager to a new server.  Note that your old server should be left in production until the procedure verified as successful. 

In NI VLM 3.0 and VLM 3.1

1.  Exporting License Server Files and Settings 
Create a backup of your existing NI VLM server using File»Backup/Restore NI VLM (see Creating an NI VLM Backup)

2. New License File
Request a new license file from National Instruments by emailing agreements@ni.com with your Service ID, new Server Name and Server Computer ID

3.Setting up a New License Server
Install NI Volume License Manager on the new server and Complete the NI VLM Getting Started Wizard. At Importing Settings from Previous NI VLM Installations select Import settings from a previous NI VLM 3.x installation and select the backup we made in step 1.
You cannot use a backup from another server except in the Getting Started Wizard. If you need to go back to this stage please refer to Backup File Was Created From Another Installation of NI VLM Error
  

In NI VLM 1.0 to NI VLM 2.1

1. Exporting License Server Files and Settings 
  1. Save the Activity Log from your old server by navigating to Options»Save Activity Log...
  2. Save the compliance log, which has a .log file extension and the configuration file nivlm.cfg. The configuration file nivlm.cfg contains both permission and client information. Therefore, moving this file will prevent you from having to re-enter this information on the new server. These files can be found at <National Instruments>\Volume License Manager
2. New License File
Request a new license file from National Instruments. Send both your new computer ID and the activity log from the old server. National Instruments uses your computer ID, the activity log, and your agreement ID to generate a new license file.

3. Setting up a New License Server
  1. Install NI Volume License Manager
  2. Install you new license file onto your new server by navigating to Options»Install License File...
  3. Replace the activity and compliance log, which both have a .log file extension, and the configuration file nivlm.cfg on the new server with copies of each from the old server. These files are located in the <National Instruments>\Volume License Manager directory. Please be sure that  VLM on the new server is closed, when copying the nivlm.cfg to the new server.
  4. Set your preferences on the new server by navigating to Options»Preferences.

Additional Information

Client Modifications

The above changes affect the server, not the clients.  The recommended way to ensure the clients still point to the proper server is to rename the new server with the Windows names of the old server.  If this option is not available please see How Do I Point Client Computers to My New Licensing Server?

WAS THIS ARTICLE HELPFUL?

Not Helpful