NI-CAN未在LabVIEW 64位中安装

更新 Jan 10, 2022

适用于

软件

  • LabVIEW

驱动

  • NI-CAN

问题详述

  • 我使用的是LabVIEW 64位版本,并且安装了NI-CAN驱动程序,可与National Instruments CAN设备通信。我在软件中看不到功能选项板。此外,如果我尝试运行NI-CAN VI,则运行箭头看起来已损坏,错误显示缺少的NI-CAN库。 NI-CAN驱动程序仅在32位版本的LabVIEW上运行吗?
  • 我在LabVIEW 2018 64位版本中的LabVIEW程序找不到我的NI-CAN驱动程序。为什么是这样?

解决方案

NI-CAN驱动程序仅适用于32位版本的LabVIEW。不支持64位版本。

 

您可以在NI-CAN驱动程序的自述文件中了解有关受支持软件的更多信息,该文件可以在驱动程序每个版本的下载页面中找到:下载NI-CAN

相关信息

如果要在LabVIEW 64位中使用CAN,LIN或FlexRay通信,则可以使用NI-XNET 。 NI-XNET平台将一系列高性能CAN,LIN和FlexRay接口与NI-XNET API结合在一起,NI-XNET API是用于读取和写入CAN,LIN和FlexRay帧的一组易于使用的常用功能,并且PXI,PCI,NI CompactDAQ和NI CompactRIO等许多不同平台上的信号。请参考以下指南,将您的应用程序移植到该新驱动程序:将NI-CAN应用程序移植到NI-XNET

 

请注意,并非所有硬件都与NI-XNET驱动程序兼容。您可以在NI-XNET驱动程序的自述文件中了解有关支持的硬件的更多信息,该文件可以在驱动程序每个版本的下载页面中找到: 下载NI-XNET