I Can't Install a Previous Version of Multisim

Updated Sep 5, 2019

Reported In

Software

  • Multisim
  • Circuit Design Suite
  • Ultiboard

Issue Details

I used to have Multisim and I decided to install a later version of Multisim. Now I can't find my previous Multisim installation and when I try to install it again, it does not let me to do so. What can I do?

Can I have two different Multisim versions installed on the same computer?

Solution

Multisim installer, among other ni products, is designed to upgrade your software. This means, that if you have version a previous version of the software, and you install a later version, the software will overwrite the previous version and will replace it with the newer version.

The only way to go back to the previous version is to uninstall the later version and then install the new version.