Error: There Is a More Recent Version of the LabVIEW Run-Time Engine Installed

Updated Apr 6, 2018

Reported In

Software

  • LabVIEW
  • LabVIEW Run-Time Engine

Issue Details

When I run my LabVIEW installer, it throws an error saying that a more recent version of the RTE is installed. Can I have multiple LabVIEW run-time engines installed on my system?

Solution

Yes, You can safely have multiple versions (years) of LabVIEW Run-Time Engine installed on the same system. You cannot, however, install an older patch of the same version of the LabVIEW Run-Time Engine.

64-bit versions of the LabVIEW Run-Time Engine are handled separately from their 32-bit counterparts.

Additional Information

For example, while you can have Run-Time Engines for LabVIEW 2015, 2016 and 2017 installed, you will not be able to install LabVIEW Run-Time Engine 2015 f3 if LabVIEW Run-Time Engine 2015 f5 has already been installed. 

 

The below screenshot from NI MAX shows a full working software stack.

WAS THIS ARTICLE HELPFUL?

Not Helpful