Error 2228 When Running LabVIEW Executable

Updated Oct 8, 2018

Reported In

Software

  • LabVIEW
  • LabVIEW Application Builder Module
  • LabVIEW Run-Time Engine

Issue Details

I built an executable. When I run this executable on a client machine, I get the following Error: VI has error type 2228: the full development version of LabVIEW is required to fix the error. How do I fix this?

Solution

One cause of this can be using incompatible versions of LabVIEW Run-Time.

When running an executable, you must have the same version of LabVIEW Run-Time as the version that the executable was developed on. If this Run-Time version is incompatible with your operating system, this error may appear.

To solve the error, you must either revert to a compatible operating system or upgrade the source code to a newer version of LabVIEW, rebuild the executable, and install the corresponding Run-Time version.

WAS THIS ARTICLE HELPFUL?

Not Helpful