TestStand and Semiconductor Module Version Matching

Updated Jun 15, 2018

Reported In

Software

  • TestStand
  • NI TestStand Semiconductor Module

Issue Details

Is it possible to install a version of the TestStand Semiconductor Module (TSM) into a different version of TestStand? For example, can I install TSM 2016 SP1 into TestStand 2017?

Solution

No, the TSM major version must match TestStand. You could install TSM 2016 SP1 into either TestStand 2016 or 2016 SP1, but not into a newer or older version of TestStand.

Additional Information

TSM relies on connecting to the TestStand engine in numerous ways which change from version to version. Further, TestStand types are often updated between versions, so TSM code would be built with different types than TestStand if the versions mismatch.

WAS THIS ARTICLE HELPFUL?

Not Helpful