NI 9185 or 9189 Shows Up as Unsupported in NI MAX

Updated Apr 2, 2018

Reported In

Hardware

  • cDAQ-9189
  • cDAQ-9185

Driver

  • NI-DAQmx 17.1

Issue Details

I recently upgraded to the NI 9185/9189. When I set up the device, NI MAX says the device is unsupported. 

Solution

You will need to upgrade to NI-DAQmx 17.1 or later. 
  1. Check the NI-DAQmx driver currently installed
  2. Check the Description section of the NI-DAQmx 17.1 download page to see if the current LabVIEW version installed is compatible.
  3. If the current version of LabVIEW is compatible, install NI-DAQmx 17.1.
  4. If the current version of LabVIEW is not compatible, upgrade first to LabVIEW 2014 or later before installing NI-DAQmx 17.1.

WAS THIS ARTICLE HELPFUL?

Not Helpful