DAQ Assistant Stuck at 'Initializing...' When Placed onto Block Diagram

Updated Dec 20, 2019

Reported In

Software

  • Measurement & Automation Explorer (MAX)
  • LabVIEW

Driver

  • NI-DAQmx

Issue Details

I put down a DAQ Assistant block, and at the initialization of DAQ Assistant, it doesn't really do anything, it just sits there and says 'Initializing...'. How do I resolve this?
When I drop DAQ Assistant onto the block diagram it won't initialize. How do I fix this?

Solution

Try the following following troubleshooting steps. 
1. Verify that our DAQmx driver is compatible with your Operating System and that DAQmx and LabVIEW are compatible
2. Try restarting the NI MAX service. We can do this by opening the Windows Services (by searching in our start menu), and looking for NI Configuration Manager >> Right Click >> Restart. This will restart the service for NI MAX. 
3. Manually reset the NI MAX database. This will revert NI-MAX files to their default state, clearing any corruption. 
4. Reinstall NI-DAQmx. You can first uninstall NI-DAQmx, and then download NI-DAQmx .
5. Upgrade NI System Configuration  if you don't already have the latest version. This will install a newer version of NI-MAX.
6. Reinstall NI MAX. First, we can uninstall NI MAX by selecting the 'NI Measurement & Automation Explorer' to remove. This will remove all software tied with NI MAX, and should be done only as a last step. We can then reinstall NI MAX

 

Additional Information

Reinstalling NI MAX will prompt you to reinstall any dependent software, such as LabVIEW.